Thundebird doesn't connect to XMPP server, doesn't go further than "initializing stream"

RESOLVED DUPLICATE of bug 741536

Status

Thunderbird
Instant Messaging
RESOLVED DUPLICATE of bug 741536
6 years ago
6 years ago

People

(Reporter: Arnaud Abélard, Unassigned)

Tracking

15 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713224758

Steps to reproduce:

On ubuntu 12.04, thunderbird 15.b1 from the mozilla-team thunderbird-next ppa.
I set up a new xmpp account for our local xmpp server (had to manually set our jabber server in the settings since Thunderbird can't do SRV records yet).


Actual results:

Waited for a little while on "Connect: Initializing Stream" then "Error: The server closed the connection". Sniffing with wireshark shows Thunderbird doest even attempt the connection. Tried to use another jabber account, using the IP address instead of the name without success.  Tried not to set a custom server in the preferences, wireshark doesn't show any connection attempt either.

Thunderbird does work smoothly with my Twitter account.

On my laptop, also with ubuntu 12.04, same ppa, same version of Thunderbird, the XMPP account works perfectly.

Tried in safe-mode and with a new clean profile: no change.


Expected results:

should have connected to the xmpp server.
(Reporter)

Comment 1

6 years ago
Also tried the different connection security settings. 

Of course the accounts work using another xmpp client.
Just to be sure, is there any proxy configured in the system or in Thunderbird on the computer where the xmpp connection doesn't work from Thunderbird?
(Reporter)

Comment 3

6 years ago
Indeed I'm using a proxy on the problematic computer. The proxy settings are only configured for HTTP and SSL (use this proxy server for all protocols is NOT checked). 

Removing the HTTP proxy or disabling the proxy settings fix the problem. 

For some reason it seems like Thunderbird is actually trying to use the HTTP proxy for the XMPP connection. That's the bug.
(In reply to Arnaud Abélard from comment #3)
> Indeed I'm using a proxy on the problematic computer. The proxy settings are
> only configured for HTTP and SSL (use this proxy server for all protocols is
> NOT checked). 
> 
> Removing the HTTP proxy or disabling the proxy settings fix the problem.

Thanks for checking (and for reporting the issue in the first place) :).

> For some reason it seems like Thunderbird is actually trying to use the HTTP
> proxy for the XMPP connection. That's the bug.

Attempting to use the HTTP proxy for IRC and XMPP connections is a known bug, that's why I asked. I'm a little surprised that the error message we display in that case is "Error: The server closed the connection" though.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 741536
You need to log in before you can comment on or make changes to this bug.