Closed Bug 778097 Opened 8 years ago Closed 8 years ago

URLBar autocomplete preferring https:// protocol

Categories

(Firefox :: Address Bar, defect)

15 Branch
x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 769994

People

(Reporter: deathslay142, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120717110313

Steps to reproduce:

Start typing the desired web address into the address bar (say "example.com"). Firefox then filled out the rest of the URL (I had, for example, typed "examp", and it now displays "example.com" in the URL bar). 


Actual results:

When pressing enter, the protocol is instantly replaced with a secure https:// protocol taking me to https://example.com, because (as far as I can tell) at some point, I have visited a page using https:// on example.com. There is no form of prior notice that when hitting enter, it'll use the secure protocol, but it always does, and nothing I do seems to be able to change it. I have no entry in my history for having visited https://example.com (in this case, the site isn't responding due to the lack of configuration for secure transport over the root), and so I can't prevent it being autofilled.

This happens on multiple websites - it seems any site with some form of https:// link in my history for the root area of the site only, results in this. Eg, a site with any of the following in the history:

https://subdomain.example.com/
https://example.com:port/

Will result in a secure autofill. When typing the autofill, the following autofill to secure:

example.com
subdomain.example.com

Neither example.com/folder, nor subdomain.example.com/folder, jump to https.


Expected results:

Ideally the autofill should default to the unsecured http:// protocol, unless a secure entry for the exact page of autofill can be verified in the history. Secured traffic is all well and good as a default, provided that it works, which is not the case for a lot of websites on the internet, which simply either fail to return or give an error.

This makes autofilling to secure based upon other 'nearby' pages, a rather error-prone method. It seems this stems from the same issue with the urlbar autofilling a domain name of a website, despite having only ever visited a subfolder and never the root domain that a website.
Component: Untriaged → Location Bar
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 769994
You need to log in before you can comment on or make changes to this bug.