Fennec uses excessive RAM

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
6 years ago
2 years ago

People

(Reporter: bug.zilla, Unassigned)

Tracking

17 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

58.75 KB, application/pdf
Details
(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

Type in something in the Awesomebar


Actual results:

Results appear after a long delay (Samsung Galaxy S, CyanogenMod 7)


Expected results:

Results should appear instantly
Do you have a large dataset of bookmarks and history, or a relatively small profile? This is probably unfixable given the notorious filesystem limitation on the original Galaxy S (2009-2010).

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 2

6 years ago
I have 10-15 bookmarks, but the history is a big as Fennec allows.
How can I find out how big is my profile?

Updated

6 years ago
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INCOMPLETE → ---
(Reporter)

Comment 3

6 years ago
Created attachment 651466 [details]
about:memory
(Reporter)

Comment 4

6 years ago
I believe this is related to high RAM usage. Both Firefox (release) and the default AOSP browser use less than 50% RAM for the same sites.

As an example, about:home uses 75-80MB and then loading say three sites (e.g. cnn.com, bbc.com etc, all mobile versions pushes it up to 110-120MB.

Firefox (release) seems fine; is this normal?

Have a look at the attached about:memory output - this was done with no other tabs open immediately after a cold start.
Summary: Fennec is slow to display Top Sites, Bookmarks and History → Fennec uses excessive RAM
(Reporter)

Comment 5

6 years ago
This is due to Adblock Plus. Disabling it reduces memory at startup to 40-45MB which is in line with the other browsers.

However, the original problem regarding the slow displaying of bookmarks and history remains. For the moment I'm using a clean profile which obviously solves the problem.

Closing for now.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → INVALID
(In reply to bug.zilla from comment #5)
> This is due to Adblock Plus. Disabling it reduces memory at startup to
> 40-45MB which is in line with the other browsers.

CC'ing Wladimir about this if that holds true.
(Reporter)

Comment 7

6 years ago
The increase in RAM does not happen with Release but happened until yesterday's build of Nightlies.
You need to log in before you can comment on or make changes to this bug.