Note: There are a few cases of duplicates in user autocompletion which are being worked on.

java.lang.NullPointerException: at org.mozilla.gecko.AwesomeBar.onCreate(AwesomeBar.java) on Honeycomb

RESOLVED FIXED in Firefox 15

Status

()

Firefox for Android
Awesomescreen
--
critical
RESOLVED FIXED
5 years ago
a year ago

People

(Reporter: Scoobidiver (away), Assigned: sriram)

Tracking

({crash, regression, topcrash})

17 Branch
Firefox 17
ARM
Android
crash, regression, topcrash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox15+ fixed, firefox16+ fixed, firefox17 fixed)

Details

(Whiteboard: [native-crash][startupcrash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
There are two crashes from the same user in 17.0a1/20120728, including bp-37128b27-3129-4733-82ba-0f8862120728.

java.lang.NullPointerException
	at org.mozilla.gecko.AwesomeBar.onCreate(AwesomeBar.java:76)
	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1048)
	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:1715)
	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:1767)
	at android.app.ActivityThread.access$1500(ActivityThread.java:122)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1005)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:132)
	at android.app.ActivityThread.main(ActivityThread.java:4028)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:491)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:844)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:602)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.AwesomeBar.onCreate%28AwesomeBar.java%29
(Reporter)

Comment 1

5 years ago
It has been hit by 2 users. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8b96a33ecbd2&tochange=2abd21593e57
It's likely a regression from bug 770928.
Blocks: 770928
Keywords: regression
Summary: java.lang.NullPointerException: at org.mozilla.gecko.AwesomeBar.onCreate(AwesomeBar.java) → java.lang.NullPointerException: at org.mozilla.gecko.AwesomeBar.onCreate(AwesomeBar.java) on Honeycomb
Whiteboard: [native-crash] → [native-crash][startupcrash]
Version: Trunk → Firefox 17
(Reporter)

Comment 2

5 years ago
It's #1 top crasher over the last 3 days.
tracking-fennec: --- → ?
Keywords: topcrash
From http://stackoverflow.com/questions/6867076/getactionbar-returns-null

It looks like we need to call setContentView(R.layout.awesomebar) _before_ calling getActionBar(). More likely, we should move the call to getActionBar() to _after_ the setContentView call.
Assignee: nobody → sriram
(Assignee)

Comment 4

5 years ago
I need to look into the code, but, Android inflates the ActionBar before doing a setContentView(). Anyways, I'll try doing that.
(Assignee)

Comment 5

5 years ago
Created attachment 647249 [details] [diff] [review]
Patch

This patch solves the crash in Honeycomb (old school way).
However, honeycomb is crazy. When I do copy or select "done", the text-selection changes and I hide the action bar -- as we should be. And then honeycomb for some reason thinks it should be showing the action-bar and shows it. And when i start typing, it goes away (as a part of textChanged listener). This is happening only in honeycomb and we dont have any control over actionbar -- which is why CustomEditText captures onSelectionChanged and passes it to AwesomeBar.
Attachment #647249 - Flags: review?(mark.finkle)
Comment on attachment 647249 [details] [diff] [review]
Patch

This will fix the crash, and I assume we have a bug filed for fixing the odd behavior on Honeycomb?
Attachment #647249 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 7

5 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/c6de46640373
Depends on: 760160
tracking this since it's a pre-requisite for uplift of bug 770928 being able to be uplifted.
status-firefox15: --- → affected
status-firefox16: --- → affected
tracking-firefox15: --- → +
tracking-firefox16: --- → +

Comment 9

5 years ago
https://hg.mozilla.org/mozilla-central/rev/c6de46640373
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 17
(Reporter)

Updated

5 years ago
Duplicate of this bug: 779446
(Assignee)

Comment 11

5 years ago
Comment on attachment 647249 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 770928
User impact if declined: Honeycomb will crash with the other patch.
Testing completed (on m-c, etc.): Landed on m-c on 07/31
Risk to taking this patch (and alternatives if risky): None. Without this patch the other cannot be landed.
String or UUID changes made by this patch: None.
Attachment #647249 - Flags: approval-mozilla-beta?
Attachment #647249 - Flags: approval-mozilla-aurora?
Attachment #647249 - Flags: approval-mozilla-beta?
Attachment #647249 - Flags: approval-mozilla-beta+
Attachment #647249 - Flags: approval-mozilla-aurora?
Attachment #647249 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 12

5 years ago
Pushed to aurora:
https://hg.mozilla.org/releases/mozilla-aurora/rev/6098f0178631
(Assignee)

Comment 13

5 years ago
Pushed to beta:
https://hg.mozilla.org/releases/mozilla-beta/rev/1fb1f90a2bc7

Updated

5 years ago
status-firefox15: affected → fixed

Updated

5 years ago
status-firefox16: affected → fixed
+ qawanted for 3.x verification
status-firefox17: --- → fixed
Keywords: qawanted

Updated

5 years ago
Keywords: qawanted
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.