On small screens, the translation interface does not scroll properly

REOPENED
Unassigned

Status

REOPENED
6 years ago
11 months ago

People

(Reporter: sheppy, Unassigned)

Tracking

(Blocks: 1 bug)

Details

(Whiteboard: [localization])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120726052803

Steps to reproduce:

Opened the localization interface on an 800x600 display


Actual results:

The interface opened but the editor for the localization editing did not scroll when I scrolled the page.


Expected results:

It should have worked!
(Reporter)

Comment 1

6 years ago
Actually, what seems to be going on is that the header bar and the toolbars take up so much vertical space in this scenario that there's no room left for content in the editor. We should figure out a way to handle this (it will be relevant on projectors and on netbooks in particular). Perhaps by hiding the page header bar while in the editor?
Another residual side effect from the scrolling CKEditor plugin, I believe.  Desperately want to remove it completely.
Depends on: 780180
Priority: -- → P1
(Assignee)

Updated

6 years ago
Version: Kuma → unspecified
(Assignee)

Updated

6 years ago
Component: Docs Platform → Editing
Product: Mozilla Developer Network → Mozilla Developer Network

Updated

5 years ago
Whiteboard: [localization]
Component: Editing → Localization
Since we last looked at this, modifications to the scrolling have been made.  Can you look at this again sheppy?
(Reporter)

Comment 4

5 years ago
There are definitely still problems scrolling this interface. The toolbar sometimes gets orphaned way above the edit box, and sometimes it becomes an extremely narrow vertical strip down its left edge. It's pretty dreadful.
Fixed via https://github.com/mozilla/kuma/commit/8987063449d2215e46b9a4fd7afbed4a45fc8395
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
We are temporarily re-enabling the scrolling plugin, so this issue will re-appear. We will remove it again when bug 913441 is closed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
See Also: → bug 1174520
See Also: → bug 1032058
See Also: → bug 1040595
Priority: P1 → --
You need to log in before you can comment on or make changes to this bug.