Repeatable hang on Full-Screen Youtube on 2nd screen

RESOLVED DUPLICATE of bug 776219

Status

()

RESOLVED DUPLICATE of bug 776219
7 years ago
7 years ago

People

(Reporter: stewart.campbell, Unassigned)

Tracking

16 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [flash-11.3])

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0
Build ID: 20120729042010

Steps to reproduce:

- Open 2 Firefox Windows, open YouTube on one of them.
- Watch a video on YouTube, open it in Full-Screen mode.
- Allow it to finish and click the replay icon on the bottom left.
- As soon as you do this (needs to be quick, before it starts playing), click anywhere in the other window.
- The plugin window will come out of full-screen and everything hangs.


Actual results:

- Firefox hangs.


Expected results:

- No Hang.
Please include the used flash plugin version in your report or are you testing the htnl5 youtube beta with a Webm video ?

In case you are using the flash based youtube:
dom.ipc.plugins.timeoutSecs is set to 45, a hanging plugin would be killed after 45 seconds. Do you waited long enough ?

Can you try to disable the flash protected mode in case you are using a recent flash version ?
http://forums.adobe.com/message/4468493 (scroll down to last resort).

I can't test youtube at the moment....
(Reporter)

Comment 2

7 years ago
I'm using Flash - version 11.3.300.268.

I definitely waited at least 45 seconds, although note that the whole of Firefox (noth Windows) is hanging, not just the plugin.

I re-tested with Protected Mode off and it no longer hangs - however the video is not rendered on the replay (the progress bar progresses and I can hear sound, but video is stuck on frame 1).

I don't seem to be able to upload attachments, but I've pastebin'ed the WinDBG analysis here: http://pastebin.mozilla.org/1722565
>although note that the whole of Firefox (noth Windows) is hanging, not just the plugin.

A hanging plugin can hang the browser until it gets killed (45s timeout)
Component: Untriaged → Plug-ins
Product: Firefox → Core

Comment 4

7 years ago
It's a dupe of bug 776219, I think.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Whiteboard: [flash-11.3]
Duplicate of bug: 776219
You need to log in before you can comment on or make changes to this bug.