Plugin repaints (at least for Flash) are completely broken when scrolling

RESOLVED DUPLICATE of bug 636952

Status

External Software Affecting Firefox
Flash (Adobe)
--
major
RESOLVED DUPLICATE of bug 636952
6 years ago
6 years ago

People

(Reporter: kael, Unassigned)

Tracking

unspecified
x86_64
Windows 7

Firefox Tracking Flags

(firefox15-)

Details

(Whiteboard: [flash-11.3])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
For the past month or so, repainting of the Flash plugin in Aurora has been completely broken - invalidated regions don't always get repainted. In particular, it's very obvious when scrolling as portions of the plugin are not repainted after the scroll occurs. I've attached video where you can see it happening on a webpage.

This happens for every flash plugin I've seen on every website I visit in FF.

Possibly related: I've also been seeing more plugin-container hangs lately, but they were never particularly rare before.

Seems similar to bug 636952, but I never saw this on the versions that bug mentions.


Relevant about:support information:


  Application Basics
        Name
        Firefox
        Version
        16.0a2
        User Agent
        Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0
  Extensions
        Name
        Version
        Enabled
        ID

        Adblock Plus
        2.1.2
        true
        {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

        Cookies Manager+
        1.5.1
        true
        {bb6bc1bb-f824-4702-90cd-35e2fb24f25d}

        Download Statusbar
        0.9.10
        true
        {D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}

        JIT Inspector
        0.1.0.0
        true
        bhackett@mozilla.com

        NoScript
        2.5
        true
        {73a6fe31-595d-460b-a920-fcc0f8843232}

        Rikaichan
        2.04
        true
        {0AA9101C-D3C1-4129-A9B7-D778C6A17F82}

        Rikaichan Japanese-English Dictionary File
        2.01.120408
        true
        rikaichan-jpen@polarcloud.com

        Test Pilot
        1.2.1
        true
        testpilot@labs.mozilla.com

        Firebug
        1.10.0
        false
        firebug@software.joehewitt.com

        Force CORS
        1.3
        false
        forcecors@ocact.us

  Important Modified Preferences
      Name
      Value
        gfx.direct3d.prefer_10_1
        true
        webgl.verbose
        true

  Graphics
        Adapter Description
        NVIDIA GeForce GTX 670
        Vendor ID
        0x10de
        Device ID
        0x1189
        Adapter RAM
        2048
        Adapter Drivers
        nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
        Driver Version
        8.17.13.142
        Driver Date
        5-15-2012
        Direct2D Enabled
        true
        DirectWrite Enabled
        true (6.1.7601.17789)
        ClearType Parameters
        ClearType parameters not found
        WebGL Renderer
        Google Inc. -- ANGLE (NVIDIA GeForce GTX 670) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)
        GPU Accelerated Windows
        1/1 Direct3D 10
        AzureBackend
        direct2d
  JavaScript
        Incremental GC
        1
(Reporter)

Comment 1

6 years ago
Bugzilla won't let me attach the recording, so here it is on youtube. Hopefully their compressor doesn't destroy all the detail:

www.youtube.com/watch?v=ZAugHeoennk
(Reporter)

Comment 2

6 years ago
Created attachment 647099 [details]
Screen capture of incorrectly repainted flash plugin
(Reporter)

Comment 3

6 years ago
Happens the same in Firefox 13 with a fresh profile (and with my same profile), so I don't think it's extensions or preferences. Odd, I don't remember seeing it in the 13 time frame, but maybe I wasn't paying attention. Could be a recent flash player update. It's not a video driver update since NVIDIA's updater doesn't work on my machine.
Yeah, I'm seeing this as well, also reports of it on the SUMO forums. I'm planning on spending some cycles seeing if this is another 11.3 issue, or what.
Kevin: What version of Flash are you using? I think Tyler may be right.
Ok, so he's what I got from tests:
With Nightly from today in all tests
Fresh profile, Flash 11.3, .268 Tearing and repainting issues
Fresh Profile, Flash 11.3, .268, HW disabled in firefox and Flash, Tearing and Repainting issues.
Fresh Profile, Flash 10.3, no tearing.

Looks like this is another issue to throw in the Flash 11.3 bucket.
Thanks Tyler. Kevin, can you confirm you're seeing the same?
(Reporter)

Comment 8

6 years ago
I've got Flash 11.3.3002.62, and I'm pretty sure it was installed recently by Adobe's updater.

Updated

6 years ago
tracking-firefox15: --- → ?
tracking-firefox15: ? → +
Whiteboard: [flash-11.3]
(In reply to Tyler Downer [:Tyler] from comment #6)
> Ok, so he's what I got from tests:
> With Nightly from today in all tests
> Fresh profile, Flash 11.3, .268 Tearing and repainting issues
> Fresh Profile, Flash 11.3, .268, HW disabled in firefox and Flash, Tearing
> and Repainting issues.
> Fresh Profile, Flash 10.3, no tearing.
> 
> Looks like this is another issue to throw in the Flash 11.3 bucket.

Tyler can we get an update with 11.3, .270 and 11.4 (beta) .252 to get a sense of if this is resolved with either of them?
Adding qawanted - either QA or Tyler running the comparison again with the latest 11.3 and 11.4 would help here.
Keywords: qawanted
I think this is a dupe of bug 636952.
I wasn't able to repro this on the page in the video test case, but easily reproduce the issue using the STR in https://bugzilla.mozilla.org/show_bug.cgi?id=636952#c8 both with Flash 11.3.300.270 and Flash 11.4.400.252 on Nightly 17.0a1 (2012-08-08).
I think I agree with comment 11. UX seems to be the same with Flash 11.3 and 11.4. Please re-add QAWANTED if there is something else you want done. But I highly suspect this is a dupe of bug 636952, as Paul already pointed out.
Keywords: qawanted
Whiteboard: [flash-11.3] → [flash-11.3][DUPEME?]
Untracking, dupe away.
tracking-firefox15: + → -
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Whiteboard: [flash-11.3][DUPEME?] → [flash-11.3]
Duplicate of bug: 636952
You need to log in before you can comment on or make changes to this bug.