Closed Bug 778701 Opened 10 years ago Closed 10 years ago

Scrollbar stops updating when zoom-in and zoom-out of the page

Categories

(Core :: Layout, defect)

17 Branch
x86
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 776836

People

(Reporter: alice0775, Assigned: mattwoodrow)

References

Details

(Keywords: regression, reproducible)

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/29bff59d3bbe
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120729030516

Original report: 
http://forums.mozillazine.org/viewtopic.php?p=12169751#p12169751

Step To Reproduce:
1. Start Nightly with clean profile(no addon and no plugins)
2. Open http://www.iinet.net.au/customers/
3. Repeat Zoom-in(Ctrl++), Observe the length of thumb and position of thumb 
4. Repeat Zoom-out(Ctrl+-), Observe the length of thumb and position of thumb 

Actual Results:
  Scrollbar stops updating.

Expected Results:
  Scrollbar should update


Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/6d5150ee06ce
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120719032015
Bad:
http://hg.mozilla.org/mozilla-central/rev/e1dcf7c892d1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120719052815
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6d5150ee06ce&tochange=e1dcf7c892d1


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/78e6e0765f35
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120718113854
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/50a9cfae125a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120718120614
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=78e6e0765f35&tochange=50a9cfae125a

Suspected: Bug 773100
if triggering this seems difficult, i had a more consistent reproduction with the statusbar ex extension enabled

New profile
install statusbarex and enable the addonsbar
navigate to http://www.chia-anime.com/alpha/K (url can be substituted with any long page,  a facebook wall or photo comment block for instance)

zoom in a few levels then refresh
scrollbar will no longer update

the issue also manifests in other ways with facebook, the comment block as mentioned when opening someones photo from your updates list will not scroll correctly leading to part of the conversation not appearing. Changing tabs forces the content to repaint and correct itself till the next time the comment list is scrolled.
Alice, i don't think 773100 is the cause here, since it landed on Aurora as well and aurora doesn't have the problem
Did bug 776836 have any effect on this bug?
if it did, its not measurable.
773100 was  checked in on the 19th

scrollbar is still working on builds from the 26th

still testing
this and bug 781414 would appear to have the same underlying cause, and it doesn't appear to involve 773100 at all.

im not even sure what Alice was testing, but the scrollbar doesn't have any problems on builds prior to and including july 27th's.
Suspect: Bug 777264
Both this bug and 781414 share the regression range on Tinderbox inbound.

Tinderbox-MI
Good
20120726180140
http://hg.mozilla.org/integration/mozilla-inbound/rev/4bfa8a24fe41

Bad
20120726210130
http://hg.mozilla.org/integration/mozilla-inbound/rev/5fe4c57fb73e

But things differ  from 781414 when we test tinderbox MC, the affected builds are offset by a build

Tinderbox-MC
Good
20120726215017
http://hg.mozilla.org/mozilla-central/rev/8b96a33ecbd2

Bad
20120727015618
http://hg.mozilla.org/mozilla-central/rev/399aff2fb74f


Both bugs appear affected by certain extensions. particularly those that add a UI items that update frequently, such as statusbarex and potentially status-4-eva
May be you are seeing different thing .

I can reproduce this problem in Nightly 07/20 build.

Step To Reproduce:
1. Start Nightly with clean profile(no addon and no plugins)
2. Open https://developer.mozilla.org/en/firefox_14_for_developers
3. Repeat Zoom-in(Ctrl++), Observe the length of thumb and position of thumb 
4. Repeat Zoom-out(Ctrl+-), Observe the length of thumb and position of thumb 

See evidence:
http://youtu.be/O1tNMm5bCjE
That could very well be,  i cannot reproduce using the page in that video.

i wonder if classic/dwm off theme would change anything.
(In reply to Danial Horton from comment #12)
> That could very well be,  i cannot reproduce using the page in that video.
> 
> i wonder if classic/dwm off theme would change anything.

No, not classic specific.
I can repro on Windows7 Aero.
This happens regardless HWA enabled/disabled.

And also this problem happens on Ubuntu.
OS: Windows 7 → All
maybe its the same bug, and it just got worse in that range i found.

i think whatever caused 778701 is related to this though, and im currently trying to determine specifically when that started occuring.
(In reply to Danial Horton from comment #1)
> if triggering this seems difficult, i had a more consistent reproduction
> with the statusbar ex extension enabled
> 
> New profile
> install statusbarex and enable the addonsbar
> navigate to http://www.chia-anime.com/alpha/K (url can be substituted with
> any long page,  a facebook wall or photo comment block for instance)
> 
> zoom in a few levels then refresh
> scrollbar will no longer update
> 
> the issue also manifests in other ways with facebook, the comment block as
> mentioned when opening someones photo from your updates list will not scroll
> correctly leading to part of the conversation not appearing. Changing tabs
> forces the content to repaint and correct itself till the next time the
> comment list is scrolled.

This sounds like a different issue - would you mind filing a separate bug and being  clearer about what you mean by "scrollbar will no longer update"? Can you scroll? Or is the scrollbar just not updating its location?
I'm able to reproduce this bug on OS X as well. Sending over to Matt to investigate since our best guess is that Bug 773100 is the cause.
Assignee: nobody → matt.woodrow
Keywords: reproducible
its the same issue, theres just multiple ways of triggering it.
Umm,
I cannot reproduce anymore in latest Nightly17.0a1.

Fixed range(m-c)
Bad:
http://hg.mozilla.org/mozilla-central/rev/2dfbe4b9403b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120808025427
Fixed:
http://hg.mozilla.org/mozilla-central/rev/b99a81e70b06
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120808092345
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2dfbe4b9403b&tochange=b99a81e70b06

Fixed range(m-i)
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/2637d896de91
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120807033326
Fixed:
http://hg.mozilla.org/integration/mozilla-inbound/rev/d75263064dc5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120807040829
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2637d896de91&tochange=d75263064dc5


This seems to be fixed by Bug 776836.
So, Should I close this bug?
Well i tried testing following exactly your steps on the range you stated, and there was no reproduction on my end, like i said above.

You originally reported this bug based on my forum post anyway, and i have since reproduced it on a slightly later build, and with the extension combination and page i use i can still reproduce it.

However, the iiNet homepage has changed since this bug was reported, and the reproduction on this bug was dependent on how long the page was.......
Anyway I close this.
fixed by Bug 776836
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 776836
You need to log in before you can comment on or make changes to this bug.