about:permissions not reflecting complete list of sites that have set cookies

RESOLVED DUPLICATE of bug 658556

Status

()

RESOLVED DUPLICATE of bug 658556
6 years ago
6 years ago

People

(Reporter: deb, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

If I go to "about:permissions" and search for "facebook", nothing is listed in the sites list.

If I then open the "manage cookies" dialog and do a search for "facebook" several cookies are listed, including five set by facebook.com itself.

The result is that I can delete these cookies, but I have no way to permanently block Facebook cookies since the site is not listed on "about:permissions".

Comment 1

6 years ago
Is this related to bug 770705?
Digging around a little more I've discovered that the permissions page doesn't reflect the cookie state even for sites that are listed.  For example, I look at "bhphoto" in my "manage cookies" dialog and there are three cookies listed, but if I click on the site in the permissions page, it says there are 0 cookies set.  

Screenshots coming.
Created attachment 647145 [details]
Cookie manager dialog showing 3 cookies set for a site.
Created attachment 647146 [details]
Permissions page claiming zero cookies set.
Created attachment 647148 [details]
Cookie manager showing 23 cookies set for Twitter.

Another cookie/permissions discrepency.
Created attachment 647149 [details]
Permissions page showing 20 Twitter cookies set.
+Margaret, who might still remember this code

Comment 8

6 years ago
This sounds like a dupe of bug 658556.
Seems likely. Very sad it's such a low priority, because we keep making it harder to actually control your cookie prefs.

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 658556
You need to log in before you can comment on or make changes to this bug.