Closed Bug 778807 Opened 9 years ago Closed 9 years ago

crash-stats.mozilla.com is showing bug numbers as stricken through, regardless of actual bug status

Categories

(Socorro :: Webapp, task)

task
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: lsblakk, Assigned: lonnen)

Details

This is very visually confusing, that bugs look fixed (struck through) when they are still NEW or ASSIGNED or other statuses that shouldn't be struck through.
@Lonnen you were the one to last work on this, right?
OS: Mac OS X → All
Hardware: x86 → All
This started happening after bug 735496 landed (but before then we didn't have the metadata in the UI at all for some time).
Depends on: 735496
OS: All → Mac OS X
Hardware: All → x86
The problem is here: https://github.com/mozilla/socorro/blob/master/webapp-php/js/socorro/bugzilla.js#L41

I used in here with an array. Since arrays are objects there's no explicit error thrown, but this line is testing whether bug.status is a property of the array, not a value in the array. This will cause any legal value of status to get marked for strike through. Patch forthcoming.
Assignee: nobody → chris.lonnen
No longer depends on: 735496
OS: Mac OS X → All
Hardware: x86 → All
Commits pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/9b34797a8278121e6e6c8ac3ef50d61f32164942
fixed bug 778807

Converts the array of status strings to an object suitable for use as a
set so that the 'in' keyword will correctly detect membership.

https://github.com/mozilla/socorro/commit/504822428f020e8d92260fd6afff73310bafe1bd
Merge pull request #752 from Lonnen/778807-strike

fixed bug 778807
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Pushed to stage, so it can go out in 18.
Target Milestone: --- → 18
Verified on stage -- bug strike-through appears to be following the correct algorithm.
Status: RESOLVED → VERIFIED
This went out in 17.3 today. It should be fixed on prod.
Target Milestone: 18 → 17
looks good on prod, thanks lonnen -- Lukas when you get a moment can you doubly-verify?
doubly-verified, thanks for the swift response on this!
Hot sauce on tacos! Thanks!
You need to log in before you can comment on or make changes to this bug.