Last Comment Bug 778845 - Must upgrade Aurora 16 to NSPR 4.9.2 final
: Must upgrade Aurora 16 to NSPR 4.9.2 final
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: 16 Branch
: All All
: -- major (vote)
: mozilla17
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-30 12:11 PDT by Kai Engert (:kaie)
Modified: 2012-08-14 14:38 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
dummy patch (27 bytes, patch)
2012-07-30 12:12 PDT, Kai Engert (:kaie)
kaie: review+
wtc: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Review

Description Kai Engert (:kaie) 2012-07-30 12:11:44 PDT
The Aurora 16 branch currently uses NSPR 4.9.2 beta.
We must upgrade it to 4.9.2 final because of policy.

There was one change between beta and final:


Bug 758837: add a comment to explain the source of the 15-char name length
limit.  Copy the null terminator from the input thread name.  r=honzab.
Comment 1 Kai Engert (:kaie) 2012-07-30 12:12:41 PDT
Created attachment 647243 [details] [diff] [review]
dummy patch
Comment 2 Kai Engert (:kaie) 2012-07-30 12:15:46 PDT
Please approve and land bug 766038 on Aurora 16, too.
Comment 3 Kai Engert (:kaie) 2012-08-02 13:50:18 PDT
Comment on attachment 647243 [details] [diff] [review]
dummy patch

permission from wtc during today's meeting
Comment 5 Wan-Teh Chang 2012-08-02 18:48:37 PDT
(In reply to Kai Engert (:kaie) from comment #4)
> https://hg.mozilla.org/integration/mozilla-inbound/rev/38b216220e60

You forgot to make a dummy change to nsprpub/config/prdepend.h.
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-08-02 19:07:04 PDT
https://hg.mozilla.org/mozilla-central/rev/38b216220e60
Comment 7 Mike Hommey [:glandium] 2012-08-02 22:55:34 PDT
Next time, please use:
$ python client.py update_nspr NSPR_4_9_2_RTM
Comment 8 Kai Engert (:kaie) 2012-08-03 18:37:56 PDT
> You forgot to make a dummy change to nsprpub/config/prdepend.h.

yes indeed, I will when landing on aurora (not to readers, this is simply to force a rebuild).


> $ python client.py update_nspr NSPR_4_9_2_RTM

That's what I did? Why do you believe I didn't?
Or do you refer to the contents of the attachment?
Comment 9 Kai Engert (:kaie) 2012-08-03 18:39:20 PDT
Wan-Teh, should we file a bug that suggests to enhance the client.py script, to automatically apply a dummy change to the header file, by appending an empty line? We can eventually clean up the lines that get added over time, but it will make sure we won't forget about it.
Comment 11 Mike Hommey [:glandium] 2012-08-03 22:40:40 PDT
(In reply to Kai Engert (:kaie) from comment #8)
> > $ python client.py update_nspr NSPR_4_9_2_RTM
> 
> That's what I did? Why do you believe I didn't?

Because it should have picked the nsprpub/config/prdepend.h change.
Comment 12 Mike Hommey [:glandium] 2012-08-03 22:41:16 PDT
(In reply to Mike Hommey [:glandium] from comment #11)
> (In reply to Kai Engert (:kaie) from comment #8)
> > > $ python client.py update_nspr NSPR_4_9_2_RTM
> > 
> > That's what I did? Why do you believe I didn't?
> 
> Because it should have picked the nsprpub/config/prdepend.h change.

I mean, it does if I run it...
Comment 13 Kai Engert (:kaie) 2012-08-06 10:35:38 PDT
> > Because it should have picked the nsprpub/config/prdepend.h change.
> I mean, it does if I run it...


I don't see code in client.py to update that file.
We do that manually.

If you saw that file changed, then that file in the release is different from the one that you were using in your local tree.
We frequently change this file in order to trigger rebuilds.

If comment 9 I suggest to enhance client.py to automatically add a dummy line to the dummy file whenever we use the script to update NSPR (or NSS, different file), so we won't forget about it and can avoid confusion.

If you like this idea, we should file a bug.
Comment 14 Wan-Teh Chang 2012-08-06 13:57:59 PDT
I think this would be a good change to client.py.

We should be more sophisticated: if the last line of prdepend.h is a blank line,
remove it. Otherwise, append a blank line.
Comment 15 Kai Engert (:kaie) 2012-08-14 14:38:40 PDT
> We should be more sophisticated: if the last line of prdepend.h is a blank
> line, remove it. Otherwise, append a blank line.

I've implemented the proposal in bug 782784.

Note You need to log in before you can comment on or make changes to this bug.