If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Session restore is broken after Bug 769960 is fixed

RESOLVED INVALID

Status

()

Toolkit
Safe Browsing
RESOLVED INVALID
5 years ago
3 years ago

People

(Reporter: ojab, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

926 bytes, text/plain
Details
(Reporter)

Description

5 years ago
Created attachment 647514 [details]
My mozconfig

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120717144008

Steps to reproduce:

1. Make a new Profile
2. Close existing tabs, open http://ya.ru
3. Close Fx
4. Start Fx
5. Click "Restore previous session" button


Actual results:

There is no "Restore previous session" button


Expected results:

Previous session restored.

r100810:a9502620734e works fine, r100811:3b312c31d1cd is broken.
(Reporter)

Comment 1

5 years ago
Firefox was build from mozilla-inbound repo.
Blocks: 769960
Component: Untriaged → Phishing Protection
Version: 14 Branch → Trunk
(Reporter)

Comment 2

5 years ago
One more thing: I'm using firefox without installation, running ~/opt/browser/dist/bin/firefox.

In r100811:3b312c31d1cd there is also two additional Warnings/Errors in Error Console:

Could not read chrome manifest 'file:///home/ojab/opt/browser/dist/bin/components/nsSafebrowsingApplication.manifest'.
Timestamp: 31.07.2012 17:36:13
Error: NS_ERROR_FILE_NOT_FOUND: Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]
Source File: chrome://browser/content/browser.js
Line: 143
Have you done a complete build since 769960 landed? nsSafebrowsingApplication.manifest doesn't exist any more, so it sounds like something in your tree is out of date.

Comment 4

5 years ago
Justin, perhaps you should add those deleted files to /browser/installer/removed-files.in
(Reporter)

Comment 5

5 years ago
Sorry for the noise, my fault. Something was rotten in my build tree, fresh hg clone works without that issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(In reply to Philip Chee from comment #4)
> Justin, perhaps you should add those deleted files to
> /browser/installer/removed-files.in

Why? I don't think anything shipped outside of jars.
(Assignee)

Updated

3 years ago
Component: Phishing Protection → Phishing Protection
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.