Browserscope.org Does Not Like Firefox's Pipelining Logic

RESOLVED WORKSFORME

Status

()

Core
Networking: HTTP
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Shane Bundy, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120730030540

Steps to reproduce:

While running Browserscope's Network test suite the tests do not progress after Latency and even manually operating it causes incorrect test results due to connection hangs in the pipeline code.


Actual results:

Tests are not performed properly when pipelining is enabled in about:config.


Expected results:

The test suite should act as they should with pipelining off (or at least like Chrome, IE, etc.)
(Reporter)

Updated

6 years ago
Summary: Browserscope.org Doe Not Like Firefox's Pipelining Logic → Browserscope.org Does Not Like Firefox's Pipelining Logic
(Reporter)

Updated

6 years ago
OS: Windows XP → All
Hardware: x86 → All
Shane, do you still see this? because it is wfm..

there is some weirdness to the browserscope results.. for instance, #4 - the max connection test should report 60 for both us and chrome. I can run it, capture a trace, and see 60 connections used for both us and chrome - and yet it reports something less than that.. 32, 17, whatever. It doesn't match the facts :( (independent of pipelines)

but the whole suite runs under pipelines ok for me..
(Reporter)

Comment 2

6 years ago
Seems to have been resolved somehow as it also wfm.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.