Lead-in of TCBS page shows misleading end date

RESOLVED DUPLICATE of bug 535830

Status

Socorro
Webapp
RESOLVED DUPLICATE of bug 535830
5 years ago
4 years ago

People

(Reporter: Robert Kaiser, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Right now we're missing aggregated crash data for 2012-07-30, so even though we have the 31st now, the latest available data is from the 29th.

When going to https://crash-stats.mozilla.com/topcrasher/byversion/Firefox/17.0a1/1/all the lead-in text says "Top 300 Crashing Signatures. 2012-07-29 through 2012-07-30." and the list below shows the data from the 29th.

This is misleading. The text should tell exactly that this is the data from the 29th.
(Reporter)

Comment 1

5 years ago
Actually, now that data has been backfilled, it says "2012-07-30 through 2012-07-31".

So, it's not wrong but just misleading. This probably means "2012-07-30 00:00 UTC through 2012-07-31 00:00 UTC". We should actually not show the date of a day there from which it doesn't actually contain data, i.e. we should subtract one day (second) from the end date. ;-)

(And yes, "2012-07-30 through 2012-07-30" is OK for the 1-day view, we don't need to special-case it there, IMHO.)
Summary: Lead-in of TCBS page can show inaccurate date → Lead-in of TCBS page shows misleading date
(Reporter)

Updated

5 years ago
Summary: Lead-in of TCBS page shows misleading date → Lead-in of TCBS page shows misleading end date

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 535830
You need to log in before you can comment on or make changes to this bug.