Click to play does not work

RESOLVED DUPLICATE of bug 779320

Status

()

RESOLVED DUPLICATE of bug 779320
6 years ago
6 years ago

People

(Reporter: etirta, Unassigned)

Tracking

14 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

1.  Enable the click to play feature.
2.  Visit the following url:
http://www.nbcolympics.com/video/badminton/court-3-aft-july-31-preliminary-round-matches.html

Btw, this need to be verified within a day or two from the reported as after several days we are not asked to login again. For ex. the following url does not require us to login again and the click to play work as expected:
http://www.nbcolympics.com/video/badminton/day-one-court-1-morning-prelims.html



Actual results:

The video box is black. Click on it, nothing happens. If the click to play is disabled, then a pop up asking us to login.


Expected results:

If the click to play block the plugins, then it should gives an indication and clicking it should play the plugins.

On the url that doesn't work, the html code of the video box is (when it's black, i.e. the click to play is enabled):
-------
<div class="d3-plugin player-wrapper" data-plugin="videoplayer" data-options="{&quot;key&quot;: &quot;court-3-aft-july-31-preliminary-round-matches&quot;, &quot;configRoot&quot;: &quot;/video/&quot;, &quot;mode&quot;: 0}">
  <div class="js-container">
    <div id="thePlayer1">
    </div>
  </div>
</div>
-------

On the url that works, the html code of the video box is:
-------
<div class="d3-plugin player-wrapper" data-plugin="videoplayer" data-options="{&quot;key&quot;: &quot;day-one-court-1-morning-prelims&quot;, &quot;configRoot&quot;: &quot;/video/&quot;, &quot;mode&quot;: 0}">
  <div class="js-container">
    <object style="visibility: visible;" id="thePlayer1" data="/code/Flash/VideoPlayer.swf?v=19" type="application/x-shockwave-flash" width="638" height="389">
      <param value="direct" name="wmode">
      <param value="0x000000" name="bgcolor">
      <param value="always" name="allowScriptAccess">
      <param value="true" name="allowFullScreen">
      <param value="." name="base">
      <param value="showinfo=0&amp;video_id=uI4OI5ecKYY&amp;forge_id=425303&amp;c=xml/config.xml&amp;disableModule=1&amp;rel=1&amp;ss=1&amp;code=logo&amp;enablejsapi=1&amp;controlroom=&amp;playerapiid=thePlayer1" name="flashvars">
    </object>
  </div>
</div>
-------

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 779320
You need to log in before you can comment on or make changes to this bug.