Add support for skew transforms to compositor-driven animations

RESOLVED FIXED in Firefox 24

Status

()

RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: dzbarsky, Assigned: dzbarsky)

Tracking

unspecified
mozilla24
Points:
---

Firefox Tracking Flags

(firefox22 wontfix, firefox23 wontfix, firefox24 fixed, b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix, b2g-v1.1hd fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Comment hidden (empty)
(Assignee)

Comment 1

7 years ago
Created attachment 647816 [details] [diff] [review]
Patch
Attachment #647816 - Flags: review?(dbaron)
(Assignee)

Comment 2

7 years ago
Created attachment 647820 [details] [diff] [review]
Patch
Attachment #647816 - Attachment is obsolete: true
Attachment #647816 - Flags: review?(dbaron)
Attachment #647820 - Flags: review?(dbaron)
(Assignee)

Comment 3

7 years ago
Created attachment 653184 [details] [diff] [review]
Updated patch
Attachment #647820 - Attachment is obsolete: true
Attachment #647820 - Flags: review?(dbaron)
Attachment #653184 - Flags: review?(dbaron)
Comment on attachment 653184 [details] [diff] [review]
Updated patch

r=dbaron, except you should also add tests for the broken things this is fixing.

You really need tests for this stuff.  If roc, cjones, you, etc., can't figure out a good way to test the whole thing, then you should at the very least write tests that let you test interpolation in the layers code, so that you can test all the value-specific code.
Attachment #653184 - Flags: review?(dbaron) → review+
(Assignee)

Updated

6 years ago
Blocks: 788549
(Assignee)

Comment 7

6 years ago
I couldn't get try to run these tests for some reason.  This patch really shouldn't change any android code, so if it fails tests we should try a clobber.

https://hg.mozilla.org/integration/mozilla-inbound/rev/9b7722e0d014
https://hg.mozilla.org/mozilla-central/rev/9b7722e0d014
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
(Assignee)

Comment 9

6 years ago
This patch is very safe and fixes a crash.
blocking-b2g: --- → leo?
(Assignee)

Comment 10

6 years ago
Comment on attachment 653184 [details] [diff] [review]
Updated patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): off main thread animations
User impact if declined: crashes on skew transform animations (which are very rare)
Testing completed: yes
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: none
Attachment #653184 - Flags: approval-mozilla-b2g18?
(Assignee)

Updated

6 years ago
blocking-b2g: leo? → ---
Comment on attachment 653184 [details] [diff] [review]
Updated patch

We don't yet know external crash volume here, so let's be cautious and approve this low risk fix.
Attachment #653184 - Flags: approval-mozilla-b2g18? → approval-mozilla-b2g18+
https://hg.mozilla.org/releases/mozilla-b2g18/rev/f5601de16bf0
status-b2g18: --- → fixed
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → wontfix
status-b2g-v1.1hd: --- → affected
status-firefox22: --- → wontfix
status-firefox23: --- → wontfix
status-firefox24: --- → fixed
You need to log in before you can comment on or make changes to this bug.