Styling for active participants is lost when changing chatrooms

RESOLVED FIXED in Thunderbird 17.0

Status

Thunderbird
Instant Messaging
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Mic, Assigned: florian)

Tracking

Trunk
Thunderbird 17.0

Thunderbird Tracking Flags

(thunderbird15 fixed, thunderbird16 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
The participant list of chatrooms shows inactive participants greyed out while active participants (= people who said something since the channel was joined) have a color.

Unfortunately this highlighting is lost when changing away from the channel. Instead, it should be available again when the user comes back to the channel.
(Assignee)

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 1

5 years ago
Created attachment 650563 [details] [diff] [review]
Patch
Assignee: nobody → florian
Status: NEW → ASSIGNED
Attachment #650563 - Flags: review?(clokep)
Comment on attachment 650563 [details] [diff] [review]
Patch

I would suggest making a hasOwnProperty method, but that's probably painful in the binding and I don't find the function calls too confusing.
Attachment #650563 - Flags: review?(clokep) → review+
(Assignee)

Comment 3

5 years ago
Created attachment 650577 [details] [diff] [review]
Patch v2

Simplified using an additional method, as suggested in comment 2.
Attachment #650563 - Attachment is obsolete: true
Attachment #650577 - Flags: review?(clokep)
Comment on attachment 650577 [details] [diff] [review]
Patch v2

Excellent, thanks!
Attachment #650577 - Flags: review?(clokep) → review+
(Assignee)

Comment 5

5 years ago
Comment on attachment 650577 [details] [diff] [review]
Patch v2

[Approval Request Comment]
I think we want this fix for Tb15, the list of participants currently look quite broken with all the nicks becoming grey again after switching back and forth between conversations, and it will look even worse once colors are added back in the message theme (bug 768919).
Attachment #650577 - Flags: approval-comm-beta?
Attachment #650577 - Flags: approval-comm-aurora?
Attachment #650577 - Flags: approval-comm-beta?
Attachment #650577 - Flags: approval-comm-beta+
Attachment #650577 - Flags: approval-comm-aurora?
Attachment #650577 - Flags: approval-comm-aurora+
comm-central: https://hg.mozilla.org/comm-central/rev/d836873c60af
comm-aurora: https://hg.mozilla.org/releases/comm-aurora/rev/6b01dcaa8057
comm-beta: https://hg.mozilla.org/releases/comm-beta/rev/d30864d616a7
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-thunderbird15: --- → fixed
status-thunderbird16: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 17.0
You need to log in before you can comment on or make changes to this bug.