Geolocation service never returns on the device

RESOLVED WORKSFORME

Status

()

Core
Geolocation
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: vingtetun, Assigned: dougt)

Tracking

Trunk
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [WebAPI:P0], URL)

Attachments

(1 attachment)

Steps to reproduce:
 - Go to http://vingtetun.org/tmp/geolocation.html
 - See the geolocation prompt, and answer yes

Actual result:
 - a Geolocation icon is shown in the status bar but nothings happens

Expected result:
 - a Geolocation icon is shown in the status bar and the result and the geolocation result are displayed on the screen


No callbacks are never fired, (no success no error).

Using logcat I can see that the underlying gps is accessed but the information never make it to the page:
E/LocSvc_adapter(  105): I/<--- int32 loc_event_cb(void*, rpc_loc_client_handle_type, rpc_loc_event_mask_type, const rpc_loc_event_payload_u_type*) line 74 RPC_LOC_EVENT_PARSED_POSITION_REPORT
D/LocSvc_eng(  105): [XXXXXX-GPS]loc_eng_deferred_action_thread navigating= 1
Actually the error callback is fired if the user deny access to geolocation. The success callback is still never fired.
blocking-basecamp: --- → ?
blocking-basecamp: ? → +
Mwu, Doug - Is this something we need partner support to resolve?
(Assignee)

Comment 3

6 years ago
Short answer:  yes.  need a partner.

Longer answer:

Sounds like everything is working as expected.... We only have a gps, so you are not going to get geolocation data very reliability inside or in dense urban area. 

Vivien, if you go outside and again.  You might need to wait for upwards of a minute with a clear view of the sky.  That could be (slightly) improved by agps.

What you really need if you want to do geolocation, is ip/wifi/cel positioning while the gps acquires a fix.
Duplicate of this bug: 779510
(In reply to Doug Turner (:dougt) from comment #3)
 > Vivien, if you go outside and again.  You might need to wait for upwards of
> a minute with a clear view of the sky.  

I can do that all the afternoon!
(Assignee)

Comment 6

6 years ago
vivien, it works better if you are at the beach w/ a cool drink in hand.  maybe you can test that out soon?
I noticed in the Mozilla office that geolocation wasn't working at all either. Is that issue I'm hitting there the same root cause as this bug?
(Assignee)

Comment 8

6 years ago
jason - read comment #3.
Doug, is this something you can drive?
Assignee: nobody → doug.turner

Updated

6 years ago
Duplicate of this bug: 779515
Assignee: doug.turner → kchen
Created attachment 658041 [details]
Sceenshot of html5demos.com/geo

It takes me about 10 minutes to get the location without A-GPS, but it works.
Whiteboard: [WebAPI:P0]
Depends on: 789385
Whiteboard: [WebAPI:P0] → [WebAPI:P0][LOE:S]
(Assignee)

Comment 12

6 years ago
kanru, is this really LOE:S?

I assert that without knowing what the plan is (are we using wifi/ip location, and who is providing that), we can not determine LOE.  Clearing for now.
Whiteboard: [WebAPI:P0][LOE:S] → [WebAPI:P0]

Updated

6 years ago
Duplicate of this bug: 793736

Comment 14

6 years ago
Also, on a related note, it would be nice if we had UI that would show the user via the status bar if we are searching for a GPS fix or actually have one, right now it's only telling that GPS is active in some way.
(Assignee)

Comment 15

6 years ago
robert, lets stay on topic. file a new bug for a new issue.

Comment 16

6 years ago
I'm trying geolocation API from Gaia Otoro (https://github.com/mozilla-b2g/gaia/commit/fc67c477f067575ed74a9c1fc4a12b8e27aec37d) and Gecko/B2G (Gecko-fcd3aa7) and still not working. There is no response or it takes forever.
(Assignee)

Comment 17

6 years ago
Manuel, did you read comment #3?
(Assignee)

Updated

6 years ago
Assignee: kchen → doug.turner

Comment 18

6 years ago
Wow, looks like I just did get a location/fix on my balcony in the middle of the city - this is after |adb remount && adb shell rm /system/lib/libulp*.so| and a phone restart (suggested by mwu).

Comment 19

6 years ago
This works now, mwu, what was the actual bug that fixed this? I guess we can dupe to that.
(Assignee)

Comment 20

6 years ago
comment 19
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.