ProBoards uses an XML declaration in text/html for character encoding information

RESOLVED FIXED

Status

Tech Evangelism
Desktop
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: Alexander L. Slovesnik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
STR:
1) Open http://readingthehpbooks.proboards.com/index.cgi?board=tps3&action=display&thread=461

Expected result: Firefox displays this page with iso-8859-1 encoding, as header of this page contains:

<?xml version="1.0" encoding="iso-8859-1"?>
<html>
<head>

Actual results: Firefox complains in Error console that:

Error: The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must to be declared in the document or in the transfer protocol.
Source File: http://readingthehpbooks.proboards.com/index.cgi?board=tps3&action=display&thread=461
Line: 0

and displays this page with wrong encoding (Cyrillic (MacCyrillic) in my case).
Per http://www.whatwg.org/specs/web-apps/current-work/multipage/parsing.html#determining-the-character-encoding , <?xml version="1.0" encoding="iso-8859-1"?> is not a supported way of declaring the encoding for text/html content. The page has been mis-authored.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

5 years ago
(In reply to Henri Sivonen (:hsivonen) from comment #1)
> Per
> http://www.whatwg.org/specs/web-apps/current-work/multipage/parsing.
> html#determining-the-character-encoding , <?xml version="1.0"
> encoding="iso-8859-1"?> is not a supported way of declaring the encoding for
> text/html content. The page has been mis-authored.

As far as I can tell, <?xml version="1.0" encoding="iso-8859-1"?> is hardcoded in ProBoards code ( http://support.proboards.com/index.cgi?board=support&action=display&thread=65998 ). Users are advised to use IE instead Firefox, because IE uses iso-8859-1 encoding.
It's unfortunate that Firefox doesn't use declared encoding, even if it was declared in wrong way, as ProBoards is very popular service for hosting internet forums ( http://en.wikipedia.org/wiki/ProBoards#Ownership_and_Service_Statistics ). BTW, Chromium on my computer shows this page properly (with iso-8859-1 encoding).
Summary: Firefox can not determine encoding on http://readingthehpbooks.proboards.com/index.cgi?board=tps3&action=display&thread=461 → ProBoards uses an XML declaration in text
Reopening as an evangelism bug. ProBoards seems to be http://www.proboards.com/
Assignee: nobody → english-us
Status: RESOLVED → REOPENED
Component: HTML: Parser → English US
Ever confirmed: true
Product: Core → Tech Evangelism
Resolution: INVALID → ---
Summary: ProBoards uses an XML declaration in text → ProBoards uses an XML declaration in text/html for character encoding information

Comment 4

3 years ago
Something should be really done with this, as even UTF-8 encoding is not autodetected in absence of BOM, even explicitly given in XML heading.

Comment 5

3 years ago
The provided URL is now redirected to 
http://readingthehpbooks.proboards.com/thread/461 
with a ooops message.

Trying with another thread
http://readingthehpbooks.proboards.com/thread/2644/proboards-upgrade

Source code is now:

<!DOCTYPE HTML>
	<!--[if IE 7]><html class="ie7"><![endif]--><!--[if IE 8]><html class="ie8"><![endif]--><!--[if IE 9]><html class="ie9"><![endif]--><!--[if gt IE 9]><!--> <html> <!--<![endif]-->
	<head>
		<meta http-equiv="content-type" content="text/html; charset=UTF-8" />

They switched to UTF-8 and HTML5

Resolved as FIXED.
Assignee: english-us → nobody
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago3 years ago
Component: English US → Desktop
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.