Closed Bug 779492 Opened 8 years ago Closed 8 years ago

The youtube.com Flash pop out video player is opened in the background

Categories

(Tech Evangelism Graveyard :: English US, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: ioana_damy, Unassigned)

Details

Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/20100101 Firefox/15.0

STR:
1. Load http://www.youtube.com in the browser. Make sure Flash is used for playing videos, not HTML5.
2. Start playing a video.
3. Click the "Full screen" button.
4. Right-click the video and select the "pop out" option.

The full screen video is paused. The video player toolbar is no longer displayed (even after moving the mouse around), so the user doesn't see any way of getting out of this screen. The pop out window is opened somewhere in the background.
This issue also reproduce on the latest Nightly and Aurora builds. It also reproduces on Firefox 4.0, so it's most probably not a regression.
1. Does this only happen on Linux?
2. Does this happen with Flash or HTML5 video?
3. If Flash, does it happen with a particular Flash version (11.2, 11.3, 11.4, etc)?
4. Does this happen with any other video sites?
5. Does this happen with any other browsers?

Thanks
Version: 15 Branch → Trunk
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #2)
> 1. Does this only happen on Linux?
> 2. Does this happen with Flash or HTML5 video?
> 3. If Flash, does it happen with a particular Flash version (11.2, 11.3,
> 11.4, etc)?
> 4. Does this happen with any other video sites?
> 5. Does this happen with any other browsers?
> 
> Thanks

1. When I initially tried to reproduce it on Windows I didn't see it because of bug 675645. I found a Windows without that bug now and this issue does reproduce on that one.
2. As you can see in comment 0 (STR: 1...), it only reproduces with Flash.
3. I am using Flash 11.2.202.236 on Ubuntu (Flash 11.2 is the last one with support for Linux, so I couldn't upgrade it) On Windows, it also reproduces with Flash 11.4 (beta 2).
4. I haven't seen the pop out option on any other sites. If you know any that have it, let me know and I'll try to reproduce it there too.
5. This issue also reproduces on Chrome, but it must be intermittent there (I couldn't reproduce it when I filed this bug but I can reproduce it today).
OS: Linux → All
Hardware: x86_64 → All
(In reply to Ioana Budnar [QA] from comment #3)
> 4. I haven't seen the pop out option on any other sites. If you know any
> that have it, let me know and I'll try to reproduce it there too.

revision3.com has a pop-out player I think.

> 5. This issue also reproduces on Chrome, but it must be intermittent there
> (I couldn't reproduce it when I filed this bug but I can reproduce it today).

It's quite possible this is a bug in Flash if it also affects Chrome.
Component: General → Flash (Adobe)
Product: Firefox → Plugins
Version: Trunk → unspecified
Firefox 15 beta 6: 20120821170930

Opening new tabs from the same contextual menu works just as opening the pop out window:

1. Start playing a video in full screen mode on youtube.com or imdb.com
2. Right-click the video.
3. Select the "About Flash..." option (on Ubuntu it works the same with the "Global Settings" option).

The About Flash (or Global Settings) page is opened in a new Firefox tab, but the user is not announced of that in any way. The tab is opened in the background while the video keeps playing in the foreground. In the past I've seen this on Chrome too, but now I can't reproduce it on it anymore.
I think this is as designed. When I right click a link and select "Open in New Tab" it opens in the background. It's also possible that this is as designed behaviour in Flash. Someone from Adobe would need to comment though.
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #6)
> I think this is as designed. When I right click a link and select "Open in
> New Tab" it opens in the background. It's also possible that this is as
> designed behaviour in Flash. Someone from Adobe would need to comment though.

When performing the same steps with HTML5, I am taken to the newly opened tab. It only opens in the background for Flash.

I don't think this is the designed behavior for Flash either, since it works ok on Google Chrome - the tabs are opened in the foreground.
(In reply to Ioana Budnar [QA] from comment #7)
> (In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #6)
> > I think this is as designed. When I right click a link and select "Open in
> > New Tab" it opens in the background. It's also possible that this is as
> > designed behaviour in Flash. Someone from Adobe would need to comment though.
> 
> When performing the same steps with HTML5, I am taken to the newly opened
> tab. It only opens in the background for Flash.
> 
> I don't think this is the designed behavior for Flash either, since it works
> ok on Google Chrome - the tabs are opened in the foreground.

You can't claim that, only Adobe can. Google uses their own sandboxed version of Flash. HTML5 uses Firefox's chrome toolkit, Adobe Flash does not. For these reasons, only Adobe can comment on whether it's designed or not. Bumping this down to UNCONFIRMED until we get confirmation from Adobe.
Status: NEW → UNCONFIRMED
Ever confirmed: false
This issue also reproduces when selecting Take Speed Test from the youtube video contextual menu.

On Mac OS X, the issue comes with a video freeze: the image freezes, the sounds sometimes goes on and sometimes freezes. The play/pause button becomes unresponsive. When the user clicks the video content, the sound plays/pauses. 

The workaround for this is going out of fullscreen mode.

Reproducible on Flash 11.4 on: Firefox 4, Firefox 17 beta 1, Firefox 18 Aurora, Firefox 19 Nightly (10/11/2012).
Resolving this WONTFIX based on the assumption this is behaving as Adobe intended. Please reopen if evidence to the contrary can be provided.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
the pop out feature is youtube's implementation.  from a user perspective, that contextual menu selection shouldn't be available when in fullscreen.  

the intended use would be from a browser window and not from fullscreen.

we have posted the suggestion to remove the context menu or break out of fullscreen before opening the video in a popout in youtube's forum...
Okay, thank you for following up :smadayag. Given this is not a Firefox bug, nor an Adobe bug, I'm moving this to Tech Evangelism.
Assignee: nobody → english-us
Component: Flash (Adobe) → English US
Product: Plugins → Tech Evangelism
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.