Closed Bug 779496 Opened 10 years ago Closed 10 years ago

"Oops" page displayed when trying to remove pre-approval

Categories

(Marketplace Graveyard :: Consumer Pages, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 779337

People

(Reporter: cboldan.mozbugs, Unassigned)

References

Details

Steps to reproduce:
1. Load Payment Settings page (make sure you have pre-approval set up) ( https://marketplace-dev.allizom.org/en-US/settings/payment )
2. Click the Remove Pre-approval button

Expected results:
Pre-approval is removed with no issues.

Actual results:
"Oops" page is displayed.

Notes/Issues:
Verified on FF17 (Win 7). Issue is only reproducing when logged in as admin.
Screencast for this issue http://screencast.com/t/JXvaQPhAEi9
Blocks: 760260
http://sentry.dmz.phx1.mozilla.com/marketplace-dev/group/1697/

SolitudeError: There was an error with that request.

Stacktrace (most recent call last):

  File "django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "amo/decorators.py", line 29, in wrapper
    return func(request, *args, **kw)

  File "amo/decorators.py", line 156, in wrapper
    return f(*args, **kw)

  File "amo/decorators.py", line 148, in wrapper
    return f(*args, **kw)

  File "amo/decorators.py", line 29, in wrapper
    return func(request, *args, **kw)

  File "mkt/account/views.py", line 160, in preapproval
    args=['cancel'])),

  File "lib/pay_server/base.py", line 145, in wrapped
    return self.call(url, method, data=data)

  File "lib/pay_server/base.py", line 123, in call
    code=code)
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 779337
You need to log in before you can comment on or make changes to this bug.