mozmill-restart fails with "cannot connect to jsbridge extension, port 24242" when using controller.startUserShutdown()

RESOLVED INVALID

Status

RESOLVED INVALID
6 years ago
2 years ago

People

(Reporter: AlexLakatos, Assigned: whimboo)

Tracking

Details

Attachments

(1 attachment, 4 obsolete attachments)

(Reporter)

Description

6 years ago
Created attachment 647977 [details]
minimizedTestcase

mozmill-restart fails to connect to jsbridge after running a test that uses controller.startUserShutdown()

Run the minimizedTestcase folder with mozmill-restart
>mozmill-restart -t minimizedTestcase/ -b path/to/nightly/firefox

Mozmill version is 1.5.17
It appears that this is specific to the way we're shutting down (simulating clicking the "#menu_FileQuitItem" menu), as other tests that use different methods are not affected. In this case, Firefox shuts down but fails to restart.

Alex: Please try to replicate this with Mozmill 2.0 so we know if it also needs to be fixed there. Also, could you try a few previous versions of Mozmill to see if this is a recent regression?
Whiteboard: [mozmill-1.5.18?]
(Assignee)

Comment 2

6 years ago
I think this bug is invalid. startUserShutdown has to be called with false because quit does not restart the application.
(Reporter)

Comment 3

6 years ago
(In reply to Henrik Skupin (:whimboo) from comment #2)
> I think this bug is invalid. startUserShutdown has to be called with false
> because quit does not restart the application.
Calling it with false gives out the same error. In addition, I get a dialog saying "Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.", even though there is no other Firefox instance running.
(Assignee)

Comment 4

6 years ago
I don't see any problem here:

$ mozmill-restart -b /Applications/Firefox/Nightly.app/ -t testquit --show-errors
TEST-START | /Volumes/data/code/mozmill/testquit/test1.js | setupModule
TEST-PASS | /Volumes/data/code/mozmill/testquit/test1.js | test1.js::setupModule
TEST-START | /Volumes/data/code/mozmill/testquit/test1.js | testQuitApplication
TEST-PASS | /Volumes/data/code/mozmill/testquit/test1.js | test1.js::testQuitApplication
INFO Passed: 2
INFO Failed: 0
INFO Skipped: 0

Which platform are you testing on? What is your log output?
(Reporter)

Comment 5

6 years ago
Created attachment 649693 [details]
minimizedTestcase

new minimized testcase, canged true for false
Attachment #647977 - Attachment is obsolete: true
(Reporter)

Comment 6

6 years ago
Created attachment 649695 [details]
logfile

logfile.log
(Reporter)

Comment 7

6 years ago
Created attachment 649701 [details]
traceback

traceback from the terminal
(Reporter)

Comment 8

6 years ago
Unzip the minimized testcase attached and run with

mozmill-restart --show-all -t mimimizedTestcase/ -b default/firefox/firefox -l logfile.log

I'm on Ubuntu 11.04 x86
(Assignee)

Updated

6 years ago
Attachment #649695 - Attachment mime type: text/x-log → text/plain
(Assignee)

Updated

6 years ago
Attachment #649695 - Attachment is obsolete: true
(Assignee)

Comment 9

6 years ago
Created attachment 650020 [details]
testcase

At least for Mozmill 1.5 this bug is invalid. I do not think that we ever allowed to continue a restart test after the application has quit by the user. That means the reason why we are failing here is test2.js under your test folder. This file is not necessary and has to be deleted. See my attached testcase how it should look like.

I will check with Mozmill 2.0 now how it works.
Assignee: nobody → hskupin
Attachment #649693 - Attachment is obsolete: true
Attachment #649701 - Attachment is obsolete: true
Status: NEW → ASSIGNED
(Assignee)

Updated

6 years ago
Whiteboard: [mozmill-1.5.18?]
(Assignee)

Comment 10

6 years ago
Works fine in Mozmill 2.0:

TEST-START | testcase/testQuit/test1.js | setupModule
TEST-START | testcase/testQuit/test1.js | testQuitApplication
TEST-PASS | testcase/testQuit/test1.js | testQuitApplication
TEST-START | testcase/testQuit/test1.js | testAfterQuit
TEST-PASS | testcase/testQuit/test1.js | testAfterQuit
TEST-START | testcase/testZZZ/test1.js | setupModule
RESULTS | Passed: 2
RESULTS | Failed: 0
RESULTS | Skipped: 0

Closing out as invalid given by my above observations.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.