nsScanner::ReadUntil() expensive

VERIFIED DUPLICATE of bug 65431

Status

()

Core
HTML: Parser
P3
normal
VERIFIED DUPLICATE of bug 65431
17 years ago
10 years ago

People

(Reporter: Chris Waterson, Assigned: Chris Waterson)

Tracking

(Blocks: 1 bug, {perf})

Trunk
mozilla0.9.1
x86
Windows 2000
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

17 years ago
nsScanner::ReadUntil() is showing up on profiles for long pages (cf. bug 56854,
where it accounts for about 4% of the overall load time). Specifically, it looks
to have an inordinately high fan-out into the string routines; see bug 56854 for
details. Filing this as a task to examine its implementation and improve it.
(Assignee)

Updated

17 years ago
Blocks: 56854
Status: NEW → ASSIGNED
Keywords: perf
Priority: -- → P3
Target Milestone: --- → mozilla0.9.1
Already have major improvements here in bug 65431.
(Assignee)

Updated

17 years ago
Depends on: 65431
(Assignee)

Comment 2

17 years ago
Excellent. I shall eagerly await the resolution of that bug, and re-evaluate!
(Assignee)

Comment 3

17 years ago
This is no longer a hotspot.

*** This bug has been marked as a duplicate of 65431 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Marking it Duplicate as per above developer comments.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.