Clicking on link containing anchor opens at top of page instead of at anchor location

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Harry Gondalf, Unassigned)

Tracking

13 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 648249 [details]
a simple html file containing a url with #bookmark

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

Firefox 13 (Win7) & FF 9 (WinXP SP3): I attempted to access a named location in a page when I click the link in another file. Target URL: http://www.bps.lk/olib/nl/nl056-p.html#d



Actual results:

Pages opens at the top, not at the internal bookmark location ‘d’, identified by 
<h4 id="d"> in the code.  Then, when I place my cursor in the address bar, and press <Enter>, the page jumps to the correct location.  


Expected results:

It should have opened at the heading <h4 id="D"> instead of at the top. Other browsers, such as Safari 5 or Opera 11.6, do not exhibit this behaviour.
(Reporter)

Comment 1

6 years ago
This same behaviour happens in FF 9.0, running in Win XP SP3
--Harry
Hello Harry,

Thanks for the bug report. Could you try to reproduce the problem in safe mode to make sure it's not caused by an extension? https://support.mozilla.com/kb/Safe+Mode
Component: Identity → Untriaged
Product: Core → Firefox
Summary: URLs containing bookmarks open at top, not at named bookmark location → Clicking on link containing anchor opens at top of page instead of at anchor location
Attachment #648249 - Attachment mime type: text/plain → text/html
(Reporter)

Comment 3

6 years ago
Thank you, Matt.  Behaviour persists when starting FF 13 in safe mode.
(Reporter)

Comment 4

6 years ago
(In reply to Matthew N. [:MattN] from comment #2)
Here’s the FF-13 troubleshooting info. Sorry for not knowing how to zip it and attach it.

================================



  Application Basics

        Name
        Firefox

        Version
        13.0.1

        User Agent
        Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20100101 Firefox/13.0.1

        Profile Folder

          Show Folder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

        Crash Reports

          about:crashes

        Memory Use

          about:memory

  Extensions

        Name

        Version

        Enabled

        ID

        Adblock Plus
        2.0.3
        true
        {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

        Autohide Bookmarks
        1.27
        true
        autohidebookmarks@radu.buzoianu

        Beef Taco (Targeted Advertising Cookie Opt-Out)
        1.3.7
        true
        john@velvetcache.org

        CodeBurner for Firebug
        1.6
        true
        firebug@tools.sitepoint.com

        cssUpdater
        0.5.1
        true
        info@cssUpdater.com

        Download Scheduler
        1.7.3
        true
        dlScheduler@ext.net

        DownloadHelper
        4.9.9
        true
        {b9db16a4-6edc-47ec-a1f4-b86292ed211d}

        Downloads in Tab
        1.00
        true
        downintab@max.max

        Dust-Me Selectors
        3.01
        true
        {3c6e1eed-a07e-4c80-9cf3-66ea0bf40b37}

        EPUBReader
        1.4.2.1
        true
        {5384767E-00D9-40E9-B72F-9CC39D655D6F}

        Firebug
        1.9.2
        true
        firebug@software.joehewitt.com

        FlashGot
        1.4.5
        true
        {19503e42-ca3c-4c27-b1e2-9cdb2170ee34}

        Fox Splitter
        2.1.2012042301
        true
        foxsplitter@piro.sakura.ne.jp

        Ghostery
        2.7.2
        true
        firefox@ghostery.com

        Greasemonkey
        0.9.20
        true
        {e4a8a97b-f2ed-450b-b12d-ee082ba24781}

        Long URL Please
        0.5.1
        true
        longurlplease@darragh.curran

        Long URL Please Mod
        0.5.1
        true
        longurlplease@tseng

        NoScript
        2.4.4rc1
        true
        {73a6fe31-595d-460b-a920-fcc0f8843232}

        RightToClick
        2.8.9
        true
        {cd617375-6743-4ee8-bac4-fbf10f35729e}

        Tab Control
        0.5.5
        true
        {39952c40-5197-11da-8cd6-0800200c9a66}

        TableTools2
        1.17
        true
        tabletools2@mingyi.org

        Toggle Web Developer Toolbar
        3.7
        true
        {c75a27d8-4529-449f-b67b-aba65d7a1c0a}

        Web Developer
        1.1.9
        true
        {c45c406e-ab73-11d8-be73-000a95be3b12}

        WordWeb one-click lookup
        5.0.1701
        true
        wcapturex@deskperience.com

        ColorZilla
        2.6.4
        false
        {6AC85730-7D0F-4de0-B3FA-21142DD85326}

        CookieCuller
        1.4
        false
        {99B98C2C-7274-45a3-A640-D9DF1A1C8460}

        Digital Pali Reader
        3.5.5
        false
        digitalpalireader@noah.yuttadhammo

        Digital Pali Reader Myanmar Tipitaka Plugin
        1.4
        false
        DPRMyanmar@noah.yuttadhammo

        Digital Pali Reader Sanksrit Dictionary
        0.1
        false
        sanskrit@noah.yuttadhammo

        Download Manager Tweak
        0.9.5
        false
        {F8A55C97-3DB6-4961-A81D-0DE0080E53CB}

        Password Exporter
        1.2.1
        false
        {B17C1C5A-04B1-11DB-9804-B622A1EF5492}

  Important Modified Preferences

      Name

      Value

        accessibility.typeaheadfind
        true

        accessibility.typeaheadfind.flashBar
        0

        browser.cache.disk.capacity
        1048576

        browser.cache.disk.smart_size.first_run
        false

        browser.cache.disk.smart_size_cached_value
        583680

        browser.history_expire_days.mirror
        180

        browser.history_expire_days_min
        0

        browser.places.importBookmarksHTML
        false

        browser.places.smartBookmarksVersion
        3

        browser.startup.homepage
        http://localhost/bpslk/library-search.php

        browser.startup.homepage_override.buildID
        20120614114901

        browser.startup.homepage_override.mstone
        13.0.1

        browser.tabs.closeWindowWithLastTab
        false

        browser.tabs.onTop
        false

        dom.event.contextmenu.enabled
        false

        extensions.checkCompatibility.11.0
        false

        extensions.checkCompatibility.13.0
        true

        extensions.checkCompatibility.6.0
        false

        extensions.lastAppVersion
        13.0.1

        font.name.sans-serif.x-western
        Lucida Sans Unicode

        font.name.serif.x-western
        Arial Unicode MS

        gfx.direct3d.prefer_10_1
        true

        keyword.URL
        http://search.yahoo.com/search?fr=panda&type=PCAFSI1190&p=

        network.cookie.lifetimePolicy
        2

        network.cookie.prefsMigrated
        true

        places.database.lastMaintenance
        1343435553

        places.history.expiration.transient_current_max_pages
        91578

        places.last_vacuum
        1312436815

        plugin.disable_full_page_plugin_for_types

        print.print_printer
        PDFCreator

        print.printer_PDFCreator.print_bgcolor
        false

        print.printer_PDFCreator.print_bgimages
        false

        print.printer_PDFCreator.print_command

        print.printer_PDFCreator.print_downloadfonts
        false

        print.printer_PDFCreator.print_edge_bottom
        0

        print.printer_PDFCreator.print_edge_left
        0

        print.printer_PDFCreator.print_edge_right
        0

        print.printer_PDFCreator.print_edge_top
        0

        print.printer_PDFCreator.print_evenpages
        true

        print.printer_PDFCreator.print_footercenter

        print.printer_PDFCreator.print_footerleft
        &PT

        print.printer_PDFCreator.print_footerright
        &D

        print.printer_PDFCreator.print_headercenter

        print.printer_PDFCreator.print_headerleft
        &T

        print.printer_PDFCreator.print_headerright
        &U

        print.printer_PDFCreator.print_in_color
        true

        print.printer_PDFCreator.print_margin_bottom
        0.5

        print.printer_PDFCreator.print_margin_left
        0.5

        print.printer_PDFCreator.print_margin_right
        0.5

        print.printer_PDFCreator.print_margin_top
        0.5

        print.printer_PDFCreator.print_oddpages
        true

        print.printer_PDFCreator.print_orientation
        0

        print.printer_PDFCreator.print_pagedelay
        500

        print.printer_PDFCreator.print_paper_data
        9

        print.printer_PDFCreator.print_paper_height
        11.00

        print.printer_PDFCreator.print_paper_size_type
        0

        print.printer_PDFCreator.print_paper_size_unit
        1

        print.printer_PDFCreator.print_paper_width
        8.50

        print.printer_PDFCreator.print_reversed
        false

        print.printer_PDFCreator.print_scaling
        1.00

        print.printer_PDFCreator.print_shrink_to_fit
        true

        print.printer_PDFCreator.print_to_file
        false

        print.printer_PDFCreator.print_unwriteable_margin_bottom
        0

        print.printer_PDFCreator.print_unwriteable_margin_left
        0

        print.printer_PDFCreator.print_unwriteable_margin_right
        0

        print.printer_PDFCreator.print_unwriteable_margin_top
        0

        privacy.clearOnShutdown.cookies
        false

        privacy.clearOnShutdown.history
        false

        privacy.clearOnShutdown.offlineApps
        true

        privacy.donottrackheader.enabled
        true

        privacy.sanitize.migrateFx3Prefs
        true

        privacy.sanitize.sanitizeOnShutdown
        true

        privacy.sanitize.timeSpan
        0

        security.enable_java
        true

        security.warn_viewing_mixed
        false

  Graphics

        Adapter Description
        Intel(R) HD Graphics Family

        Vendor ID
        0x8086

        Device ID
        0x0102

        Adapter RAM
        Unknown

        Adapter Drivers
        igdumdx32 igd10umd32

        Driver Version
        8.15.10.2219

        Driver Date
        10-1-2010

        Direct2D Enabled
        true

        DirectWrite Enabled
        true (6.1.7600.16385)

        ClearType Parameters
        ClearType parameters not found

        WebGL Renderer
        Google Inc. -- ANGLE (Intel(R) HD Graphics Family) -- OpenGL ES 2.0 (ANGLE 1.0.0.963)

        GPU Accelerated Windows
        2/2 Direct3D 10

        AzureBackend
        direct2d

  JavaScript

        Incremental GC
        1

  Library Versions

        Expected minimum version

        Version in use

        NSPR
        4.9
        4.9

        NSS
        3.13.4.0 Basic ECC
        3.13.4.0 Basic ECC

        NSS Util
        3.13.4.0
        3.13.4.0

        NSS SSL
        3.13.4.0 Basic ECC
        3.13.4.0 Basic ECC

        NSS S/MIME
        3.13.4.0 Basic ECC
        3.13.4.0 Basic ECC
(Reporter)

Comment 5

6 years ago
CORRECTION:

The behaviour does NOT occur in safe mode.  There it must be some add-on or extension that's to blame.

Thank  you, Matt, for your help; my apologies for the false alarm.

Any idea, from looking at the info above, what might be the problem?

-harry g.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
It's hard to say which of those extensions would cause this because I haven't heard of many of them.  I suspect one of them is listening for events while the page is loading and preventing the default action of scrolling to the anchor.

It would be very useful if you disable your extensions one at a time until you figure out which one it is.  Then we can contact the author so it can be fixed for all its users.

Thanks
(Reporter)

Comment 7

6 years ago
Yes, I disabled them one at a time until I found the culprit: Ghostery. This is an ad-blocker/anti-spyware app that also reports, blocks, and erases those intrusive flash supercookies.  I will continue the search for a fix with the Ghostery people.

Thanks again for your help.

-Harry
You need to log in before you can comment on or make changes to this bug.