Last Comment Bug 779793 - Properly send a NO_PROVIDER error when there is no options to handle a WebActivity
: Properly send a NO_PROVIDER error when there is no options to handle a WebAct...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: Etienne Segonzac (:etienne)
: Jason Smith [:jsmith]
:
Mentors:
Depends on:
Blocks: 715814
  Show dependency treegraph
 
Reported: 2012-08-02 03:33 PDT by Etienne Segonzac (:etienne)
Modified: 2012-09-14 18:22 PDT (History)
5 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch proposal (1.49 KB, patch)
2012-08-02 03:33 PDT, Etienne Segonzac (:etienne)
21: review+
Details | Diff | Splinter Review

Description Etienne Segonzac (:etienne) 2012-08-02 03:33:58 PDT
Created attachment 648292 [details] [diff] [review]
Patch proposal

Looks like |ActivitiesDb.find| will always call the success callback with a result where |result.options| is an empty array if no provider was found.

Updating the "no matching activity registered" condition accordingly.
Comment 1 Ryan VanderMeulen [:RyanVM] 2012-08-04 08:32:36 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/02cbcf0159fa
Comment 2 Ed Morley [:emorley] 2012-08-04 10:11:41 PDT
Backed out as part of the mass tree revert due to bustage caused by other landings:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c801b99d726f

Once the tree is open again, this can reland :-)
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-08-04 12:06:25 PDT
Re-landed.
https://hg.mozilla.org/integration/mozilla-inbound/rev/91e49679104c
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-08-04 18:42:05 PDT
https://hg.mozilla.org/mozilla-central/rev/91e49679104c

Note You need to log in before you can comment on or make changes to this bug.