A table cell containing an image may not show the cell's border and/or padding

RESOLVED FIXED in mozilla0.9.6

Status

()

Core
Layout: Tables
P3
normal
RESOLVED FIXED
17 years ago
16 years ago

People

(Reporter: karnaze (gone), Assigned: karnaze (gone))

Tracking

({testcase})

Trunk
mozilla0.9.6
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: PATCH CANDIDATE_094, URL)

Attachments

(4 attachments, 1 obsolete attachment)

(Assignee)

Description

17 years ago
If a table cell contains an image and the cell's width and/or heigth is 
determined by the image, the cell's full border and padding will likely not be 
shown. For a 1 pixel border and 1 pixel paddding this will mean that the padding 
is not shown. Attachment #1 [details] [diff] shows a more severe example.
(Assignee)

Comment 1

17 years ago
Created attachment 32479 [details]
test case
(Assignee)

Comment 2

17 years ago
Created attachment 32482 [details]
correct test case (ignore previous one)
(Assignee)

Comment 3

17 years ago
Moving to m0.9.1. The image must not be in the cache to see the bug. This bug 
was discovered after looking at the test case in bug 14929.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 4

17 years ago
Created attachment 32485 [details] [diff] [review]
patch to fix the bug
(Assignee)

Updated

17 years ago
Keywords: patch

Comment 5

17 years ago
Chris, I tried your patch. As a first step I downloaded the testcase to my local 
disc as the lxr gif access does not work and adjusted the image src path. Then I 
started the viewer and as the table is larger then 600px I hit the maximise 
button and could eyewitness the next reflow bug. You should fix this as well 
within this patch :-).

Comment 6

17 years ago
Created attachment 32523 [details]
screenshot of the maximize problem
(Assignee)

Comment 7

17 years ago
Moving m0.9.3
Target Milestone: mozilla0.9.1 → mozilla0.9.3

Comment 8

17 years ago
Missed 0.9.3.
Target Milestone: mozilla0.9.3 → mozilla0.9.4

Comment 9

16 years ago
I can reproduce this on Linux, so marking OS->All

To Reproduce, using Mozilla on Linux, go to: 
http://gbreland.one-arm.com/mozilla/jump.html

Page will appear correctly.  Now click on <reload> and the problem will show
itself.  I used style="border-width:15px;" to make the problem obvious.
OS: Windows NT → All
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.5
Attachment #32479 - Attachment is obsolete: true
Keywords: testcase
(Assignee)

Comment 10

16 years ago
reassigning to m0.9.6
Target Milestone: mozilla0.9.5 → mozilla0.9.6
(Assignee)

Updated

16 years ago
Keywords: patch
Whiteboard: PATCH

Comment 11

16 years ago
Actually, you need to do a <shift><reload> with my example at:

  http://gbreland.one-arm.com/mozilla/jump.html

This is a big problem as can be seen with my other site.  Notice how the logo
bounes up and down when <reload> and <shift><reload>

  http://www.mozillanews.org/
(Assignee)

Comment 12

16 years ago
Comment on attachment 32485 [details] [diff] [review]
patch to fix the bug

sr=attinasi, r=alexsavulov
Attachment #32485 - Flags: superreview+
Attachment #32485 - Flags: review+
(Assignee)

Comment 13

16 years ago
Bernd, I can't reproduce the problem you were having. I first tried 
putting the image locally and then changed the test case to access the image 
from mozilla.org to get more of a time delay.
Priority: -- → P3
(Assignee)

Comment 14

16 years ago
Created attachment 56735 [details] [diff] [review]
same patch made from a more current tree
(Assignee)

Comment 15

16 years ago
The patch is in.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Whiteboard: PATCH → PATCH CANDIDATE_094
You need to log in before you can comment on or make changes to this bug.