Closed Bug 779913 Opened 8 years ago Closed 7 years ago

Pasting something in textarea makes it scroll to the start at nujij.nl

Categories

(Core :: DOM: Editor, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: martijn.martijn, Unassigned)

References

()

Details

(Keywords: testcase)

Attachments

(1 file)

Steps to reproduce:
- Go to url, scroll to the bottom, there you can see the comment box textarea
- Type something in the textarea, press enter untill you get scrollbars in the textarea
- Press ctrl-V or right-click paste something in the textarea

Expected result:
- Textarea is not scrolled to the beginning.

Actual result:
- Textarea is scrolled to the beginning.

I'm not completely sure this is a bug in Firefox, but I don't see this problem in Google Chrome or Internet Explorer or Opera.

Also, it doesn't look like a regression, I can see the bug also in a build from beginning 2008.

I haven't looked for a testcase yet, so marking unconfirmed for now.
The following code(extracted from web page) causes this problem

<textarea name="body" id="comment" style="width: 100%; height: 75px; border: medium none;" tabindex="1"></textarea>
<script>// Prevent link pasting from Tynt
  $(function () {
    $('#comment').live('paste', function (eventObject) {
      setTimeout(function() {
        $('#comment').val( $('#comment').val().replace(new RegExp( '\\s+Lees meer: http://www.nujij.nl/.+?#[^\\s]+', 'i' ),'') );
      }, 50);
    });
  });
</script>
Attached file testcase html
Cannot reproduce
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9a7pre) Gecko/2007072517 Minefield/3.0a7pre
Can reproduce:
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9a7pre) Gecko/2007072605 Minefield/3.0a7pre

Bonsai log:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-07-25+17%3A00%3A00+&maxdate=2007-07-26+05%3A00%3A00&cvsroot=%2Fcvsroot

Triggered by: bug 280959 Adding support for cut, copy, paste events.

So, I do not think this is a regression.
Just hit Bug 231389 



















l;ll;:
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 231389
Oops, sorry my bad, bug 231389 is different
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Status: REOPENED → UNCONFIRMED
Ever confirmed: false
Alice, thanks for the testcase! I can't seem to reproduce this issue anymore in Firefox 22 beta. I can still reproduce in Firefox 20 stable, though.

I guess this can be marked worksforme?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Fixed by Bug 829606
Status: NEW → RESOLVED
Closed: 8 years ago7 years ago
Resolution: --- → FIXED
Depends on: 829606
You need to log in before you can comment on or make changes to this bug.