Closed Bug 779949 Opened 8 years ago Closed 8 years ago

running mochitests or talos tests on panda board fail to run after we load the initial page

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: jmaher, Assigned: jmaher)

References

Details

(Whiteboard: u=panda c=ateam p=2)

I have been unable to get mochitests running on panda board (android 4.0.4) and fennec 17 for the last couple weeks.  I have been able to run from the same build and toolchain on my tegra with no problem.  When comparing the logs, a few things are out of order, but these things are missing at the end of the logcat output on the panda:

01-04 05:55:35.566 I/GeckoApp( 1561): Got message: Tab:ViewportMetadata
01-04 05:55:35.576 I/GeckoApp( 1561): Got message: Content:StateChange
01-04 05:55:35.576 I/GeckoApp( 1561): State - 786448
01-04 05:55:35.576 I/GeckoApp( 1561): Got a document stop
01-04 05:55:35.576 I/GeckoToolbar( 1561): zerdatime 179274 - Throbber stop


by missing, I mean nothing at all shows up in the logcat output.  I have more debugging to do, but this is a non starter for using panda boards to run automated tests.

For comparison we can run reftests completely on the boards with the same build and tool chain.
I have a phone with Android 4.1.1 (Nexus S), and I can run mochitests just fine on there with the same build of fennec and the same tools/tests that fail on my panda board.

I suspect the problem is our OS build, maybe a resource that we depend on (either directly or indirectly) which isn't available and we are hanging.
Whiteboard: u=panda c=ateam p=2
adjusting the resolution from the bootargs resolved this.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Assignee: nobody → jmaher
You need to log in before you can comment on or make changes to this bug.