Last Comment Bug 780063 - B2G RIL : ICC lock cannot work on Otoro
: B2G RIL : ICC lock cannot work on Otoro
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: ARM Gonk (Firefox OS)
: -- normal (vote)
: mozilla17
Assigned To: Yoshi Huang[:allstars.chh] (OOO ~ 9.30)
:
:
Mentors:
Depends on:
Blocks: 774114
  Show dependency treegraph
 
Reported: 2012-08-02 20:00 PDT by Yoshi Huang[:allstars.chh] (OOO ~ 9.30)
Modified: 2012-08-06 17:11 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
WIP: ICC IO with AID (9.88 KB, patch)
2012-08-03 10:04 PDT, Yoshi Huang[:allstars.chh] (OOO ~ 9.30)
no flags Details | Diff | Splinter Review
ICC IO with AID (9.88 KB, patch)
2012-08-06 02:47 PDT, Yoshi Huang[:allstars.chh] (OOO ~ 9.30)
vicamo: review+
Details | Diff | Splinter Review

Description Yoshi Huang[:allstars.chh] (OOO ~ 9.30) 2012-08-02 20:00:51 PDT
ICC lock(pin, pin2, puk, puk2) cannot work on Otoro, 
the reason is for those SIM_{PIN|PIN2|PUK|PUK2}_REQEUST they also need another parameter for AID.
Comment 1 Yoshi Huang[:allstars.chh] (OOO ~ 9.30) 2012-08-03 10:04:17 PDT
Created attachment 648757 [details] [diff] [review]
WIP: ICC IO with AID

WIP patch
Comment 2 Yoshi Huang[:allstars.chh] (OOO ~ 9.30) 2012-08-06 02:47:34 PDT
Created attachment 649224 [details] [diff] [review]
ICC IO with AID

Hi, Vicamo
Can you help to review this patch for me ?

Thanks
Comment 3 Vicamo Yang [:vicamo][:vyang] 2012-08-06 04:07:51 PDT
Comment on attachment 649224 [details] [diff] [review]
ICC IO with AID

Review of attachment 649224 [details] [diff] [review]:
-----------------------------------------------------------------

Sweet!
Comment 4 Vicamo Yang [:vicamo][:vyang] 2012-08-06 04:08:55 PDT
Don't forget r=me if you're going to push it ;)
Comment 5 Yoshi Huang[:allstars.chh] (OOO ~ 9.30) 2012-08-06 06:58:44 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/9cf053125943
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-08-06 17:11:33 PDT
https://hg.mozilla.org/mozilla-central/rev/9cf053125943

Note You need to log in before you can comment on or make changes to this bug.