Crashes when program close while resolving hostname

VERIFIED WORKSFORME

Status

()

Core
Networking
--
critical
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Stephen Anderson, Assigned: neeti)

Tracking

Trunk
mozilla0.9.2
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.8.1+)
Gecko/20010427
BuildID:    2001042704

If mozilla is in the middle of resolving a bogus hostname when you close the
application, it crashes.

Reproducible: Always
Steps to Reproduce:
1. Open mozilla with a blank page.
2. Goto http://www.975mix.com
3. While "resolving hostname" close mozilla.

Actual Results:  Boom

Expected Results:  Close with no boom

Talkbacks:
TB29722098E
TB29721994G
(Assignee)

Comment 1

17 years ago
This is the stack trace we get on the crash.


nsHTTPPipelinedRequest::OnStopRequest(nsHTTPPipelinedRequest * const 0x04a11250, 
nsIRequest * 0x04a13bd0, nsISupports * 0x049fe5b0, unsigned int 2152398850) line 
866 + 26 bytes
nsSimpleStreamProvider::OnStopRequest(nsSimpleStreamProvider * const 0x04a13d90, 
nsIRequest * 0x04a13bd0, nsISupports * 0x049fe5b0, unsigned int 2152398850) line 
56 + 53 bytes
nsOnStopRequestEvent::HandleEvent() line 159
nsARequestObserverEvent::HandlePLEvent(PLEvent * 0x04a1ecc4) line 64
PL_HandleEvent(PLEvent * 0x04a1ecc4) line 588 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00a0b9d0) line 518 + 9 bytes
nsEventQueueImpl::ProcessPendingEvents(nsEventQueueImpl * const 0x00a0baa0) line 
374 + 12 bytes
NS_ShutdownXPCOM(nsIServiceManager * 0x00000000) line 477
main(int 1, char * * 0x00954310) line 1308 + 8 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77f1b9ea()

Target Milestone: --- → mozilla0.9.2
(Reporter)

Comment 2

17 years ago
Can somebody take a look at this?  This has gotten more painful in recent
builds.  In build 20001050320 it crashes mozilla about 2/3 of the time.  But,
1/3 of the time one thread doesn't let go on shtdown and I get a rougue mozilla
process which burns 99% of my cpu time.  Mozilla looks like it's gone but my
machine becomes practially unusable until I can hunt it down and kill it in the
taskmanager.
(Reporter)

Comment 3

17 years ago
This bug has vanished for me as of build 2001050804.  I suspect the fixes that
went in for bug 78479 also took care of fixing this one.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 4

17 years ago
verified wfm:  Win2k 2001082303
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.