If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Find dialog doesn't open unless you delete the component.reg

VERIFIED WONTFIX

Status

SeaMonkey
UI Design
P3
normal
VERIFIED WONTFIX
17 years ago
9 years ago

People

(Reporter: Blake Ross, Assigned: Simon Fraser)

Tracking

({regression})

Trunk
mozilla0.9.2
x86
Windows 2000
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [f/r])

(Reporter)

Description

17 years ago
Find dialog won't open in Navigator for me anymore in a new tip build (works in 
Editor):

JavaScript error:
 line 0: uncaught exception: [Exception... "Component returned failure code: 0x8
0040154 (NS_ERROR_FACTORY_NOT_REGISTERED) [nsIInterfaceRequestor.getInterface]"
 nsresult: "0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED)"  location: "JS frame :
: chrome://global/content/xulBindings.xml#browser.webBrowserFind (getter) :: ong
et :: line 0"  data: no]
Removing my component.reg fixes this.  This is the second time in the past 2 or
3 days where I've needed to remove my component.reg.  Did something change?

Comment 2

17 years ago
Converting this to a component.reg bug.  Why do we have
to keep removing this file?  looking for a new owner
in case smfr doesn't want to be on the hot seat...
Keywords: nsCatFood, regression
Summary: No longer able to open Find from Navigator → component.reg removal is needed sometimes

Comment 3

17 years ago
dbaron says to look at bug 46863

Comment 4

17 years ago
apparently, optimized builds don't run regxpcom,
so if some module {load,unload} callbacks change
you will have problems.  This was done to save startup
time.

How about doing this only for the official build case?

Comment 5

17 years ago
*** Bug 78054 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

17 years ago
nsIWebBrowserFind moved to a different module, so I guess I should have changed 
its IID. I'll do that.

Other than this Find issue, I'm not the person to own a general 'need to remove 
XPCOM registry' bug.
Summary: component.reg removal is needed sometimes → Find dialog doesn't open unless you delete the component.reg

Updated

17 years ago
Priority: -- → P3
Target Milestone: --- → mozilla0.9.2

Updated

17 years ago
Whiteboard: [f/r]
(Assignee)

Comment 7

17 years ago
This won't affect installed builds, where the components reg is recreated.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
i haven't encountered this, so [rubberstamp] vrfy. still a problem for anyone?
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

9 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.