Last Comment Bug 780110 - Trash folder not automatically created with new Feed account, only on restart; this causes folder deletion problems until restart.
: Trash folder not automatically created with new Feed account, only on restart...
Status: RESOLVED FIXED
[fixed by bug 529131]
:
Product: MailNews Core
Classification: Components
Component: Feed Reader (show other bugs)
: 15
: x86_64 Windows 7
: -- normal (vote)
: Thunderbird 24.0
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 843301 (view as bug list)
Depends on: 529131 796234
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-03 04:19 PDT by Fabian Erdmann
Modified: 2013-06-26 01:01 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Fabian Erdmann 2012-08-03 04:19:26 PDT
User Agent: Opera/9.80 (Windows NT 6.1; WOW64; U; de) Presto/2.10.289 Version/12.01

Steps to reproduce:

most times when i recieve new RSS feeds under "Blogs & News-Feeds" and i click on "Löschen" (delete) with the single messages nothing happens. When i close Thunderbird and restart it and try to delete it again it works.



Expected results:

Deleting of messages directly without the need of a restart of Thunderbird.
Comment 1 Luc DISCHERT 2012-08-03 04:28:43 PDT
This action results in two errors in the console (the second occurs 4 times) :

Error : An error occurred executing the button_delete command: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgDBView.doCommand]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://messenger/content/folderDisplay.js :: FolderDisplayWidget_doCommand :: line 1793"  data: no]
Source file : chrome://global/content/globalOverlay.js
Line : 100

Erreur : Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgFolder.getStringProperty]
Fichier source : chrome://messenger/content/folderPane.js
Ligne : 2468
Comment 2 Luc DISCHERT 2012-08-03 04:51:55 PDT
In fact only the first error occurs. Another one occurs when trying to delete a feed :

Erreur : NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgFolder.deleteSubFolders]
Fichier source : chrome://messenger/content/folderPane.js
Ligne : 2228
Comment 3 Luc DISCHERT 2012-08-03 06:25:54 PDT
In fact shift+delete works fine. I think the problem is that no trash exists before restarting TB. So the fix will be to create a trash when creating "Blogs & News-Feeds" account.
Comment 4 Fabian Erdmann 2012-08-03 06:47:37 PDT
It may be (i cannot say 100% sure) that it only regards the Feed subscriptions which i imported from my Thunderbird installation on another operating system.
I will check if it regards all subscriptions in the next time.
Comment 5 Luc DISCHERT 2012-08-03 12:42:28 PDT
After checking, the trash file is correctly created on the disk, but the database is not updated.
Comment 6 alta88 2012-08-09 08:06:40 PDT
true, if a new feed account is created, Trash is not.  a restart autocreates Trash.  so until a restart, deleting any added folder will cause an error.
Comment 7 alta88 2013-02-28 08:49:24 PST
*** Bug 843301 has been marked as a duplicate of this bug. ***
Comment 8 alta88 2013-06-24 09:30:30 PDT
fixed in Tb by converting all acct creation to new codepath, in bug 529131.

Note You need to log in before you can comment on or make changes to this bug.