Last Comment Bug 780125 - B2G Armv7a ICS debug builds fail with "configure: error: installation or configuration problem: C compiler cannot create executables."
: B2G Armv7a ICS debug builds fail with "configure: error: installation or conf...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: ARM Gonk (Firefox OS)
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 776045
  Show dependency treegraph
 
Reported: 2012-08-03 05:55 PDT by Ed Morley [:emorley]
Modified: 2012-08-03 11:45 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Ed Morley [:emorley] 2012-08-03 05:55:36 PDT
Armv7a ICS debug builds are failing on some trees even after a clobber, with:
{
checking whether the host c compiler (gcc    ) works... yes
checking whether the host c++ compiler (c++    ) works... yes
checking for /builds/slave/profiling-ics-armv7a-gecko-dbg/build/gonk-toolchain/prebuilt/linux-x86/toolchain/arm-eabi-4.4.3/bin/arm-eabi-gcc... /builds/slave/profiling-ics-armv7a-gecko-dbg/build/gonk-toolchain/prebuilt/linux-x86/toolchain/arm-eabi-4.4.3/bin/arm-eabi-gcc
checking for gcc... /builds/slave/profiling-ics-armv7a-gecko-dbg/build/gonk-toolchain/prebuilt/linux-x86/toolchain/arm-eabi-4.4.3/bin/arm-eabi-gcc
checking whether the C compiler (/builds/slave/profiling-ics-armv7a-gecko-dbg/build/gonk-toolchain/prebuilt/linux-x86/toolchain/arm-eabi-4.4.3/bin/arm-eabi-gcc -mandroid -fno-short-enums -fno-exceptions  -mandroid -L/builds/slave/profiling-ics-armv7a-gecko-dbg/build/gonk-toolchain/out/target/product/generic/obj/lib -Wl,-rpath-link=/builds/slave/profiling-ics-armv7a-gecko-dbg/build/gonk-toolchain/out/target/product/generic/obj/lib --sysroot=/builds/slave/profiling-ics-armv7a-gecko-dbg/build/gonk-toolchain/out/target/product/generic/obj/ -llog ) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.
*** Fix above errors and then restart with               "make -f client.mk build"
make[2]: *** [configure] Error 1
make[2]: Leaving directory `/builds/slave/profiling-ics-armv7a-gecko-dbg/build'
make[1]: *** [/builds/slave/profiling-ics-armv7a-gecko-dbg/build/obj-b2g/Makefile] Error 2
}

eg:
https://tbpl.mozilla.org/php/getParsedLog.php?id=14088951&tree=Profiling

https://tbpl.mozilla.org/php/getParsedLog.php?id=14087199&tree=Fx-Team
https://tbpl.mozilla.org/php/getParsedLog.php?id=14089245&tree=Fx-Team
https://tbpl.mozilla.org/php/getParsedLog.php?id=14092224&tree=Fx-Team
https://tbpl.mozilla.org/php/getParsedLog.php?id=14092277&tree=Fx-Team
https://tbpl.mozilla.org/php/getParsedLog.php?id=14093345&tree=Fx-Team

https://tbpl.mozilla.org/php/getParsedLog.php?id=14092057&tree=Services-Central
Comment 1 Ed Morley [:emorley] 2012-08-03 05:59:36 PDT
Ms2ger just pointed out that it's actually hidden on m-c/inbound (and busted there too); so this isn't tree-specific at all.

Please can people CC me on bugs that involve enabling new builds (particularly when they need to be hidden on some trees), since it will save me thinking things are broken when they are not :-)
Comment 2 Ed Morley [:emorley] 2012-08-03 06:07:11 PDT
I've now hidden B2G ics_armv7a_gecko-debug on these trees as well:
{try,profiling,fx-team,services-central,ionmonkey}

I'm not sure which other trees (eg twigs) will end up running these once they merge from m-c tip; but we can deal with them as and when.
Comment 3 Ted Mielczarek [:ted.mielczarek] 2012-08-03 08:39:28 PDT
Can we get someone to grab config.log from one of these builds? It's really hard to tell why it's failing otherwise.
Comment 4 Chris AtLee [:catlee] 2012-08-03 08:58:48 PDT
configure:2061: checking for gcc 
configure:2174: checking whether the C compiler (/builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/prebuilt/linux-x86/toolchain/arm-eabi-4.4.3/bin/arm-eabi-gcc -mandroid -fno-short-enums -fno-exceptions  -mandroid -L/builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/out/target/product/generic/obj/lib -Wl,-rpath-link=/builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/out/target/product/generic/obj/lib --sysroot=/builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/out/target/product/generic/obj/ -llog ) works
configure:2190: /builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/prebuilt/linux-x86/toolchain/arm-eabi-4.4.3/bin/arm-eabi-gcc -o conftest -mandroid -fno-short-enums -fno-exceptions  -DANDROID -isystem /builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/bionic/libc/arch-arm/include -isystem /builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/bionic/libc/include/ -isystem /builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/bionic/libc/kernel/common -isystem /builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/bionic/libc/kernel/arch-arm -isystem /builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/bionic/libm/include -I/builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/frameworks/base/opengl/include -I/builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/frameworks/base/native/include -I/builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/hardware/libhardware/include -I/builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/hardware/libhardware_legacy/include -I/builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/system -I/builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/system/core/include -isystem /builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/bionic -I/builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/frameworks/base/include -I/builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/external/dbus  -I/builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/frameworks/base/services/sensorservice -I/builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/frameworks/base/services/camera -mandroid -L/builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/out/target/product/generic/obj/lib -Wl,-rpath-link=/builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/out/target/product/generic/obj/lib --sysroot=/builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/out/target/product/generic/obj/ -llog  conftest.c  -lstlport 1>&5
/builds/slave/fx-team-ics-armv7a-gecko-dbg/build/configure: line 2189: /builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/prebuilt/linux-x86/toolchain/arm-eabi-4.4.3/bin/arm-eabi-gcc: No such file or directory


The proper path for gcc is
/builds/slave/fx-team-ics-armv7a-gecko-dbg/build/gonk-toolchain/prebuilt/linux-x86/toolchain/arm-linux-androideabi-4.4.x/bin/arm-linux-androideabi-gcc
Comment 5 Chris AtLee [:catlee] 2012-08-03 09:12:22 PDT
Checked in http://hg.mozilla.org/build/buildbot-configs/rev/dd4e9e320027 - the debug builds were pointing at the wrong mozconfig.
Comment 6 Ed Morley [:emorley] 2012-08-03 11:45:44 PDT
Builds have gone green; starred all the busted ones and unhidden on:
{mozilla-central,mozilla-inbound,try,profiling,fx-team,services-central,ionmonkey}

Note You need to log in before you can comment on or make changes to this bug.