Last Comment Bug 780139 - The sense of some GCLI command boolean parameters are wrong
: The sense of some GCLI command boolean parameters are wrong
Status: RESOLVED FIXED
[gclicommands]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: Trunk
: All All
: P2 normal (vote)
: Firefox 17
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks: GCLICMD
  Show dependency treegraph
 
Reported: 2012-08-03 06:56 PDT by Joe Walker [:jwalker] (needinfo me or ping on irc)
Modified: 2012-08-27 05:23 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-08-03 06:56:39 PDT
We can't have boolean parameters with a defaultValue (because all boolean params have an implied defaultValue of true), so we certainly can't have one with a defaultValue of true.
Comment 1 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-08-03 06:59:03 PDT
Also spaceBeforeConditional
Comment 2 Michael Ratcliffe [:miker] [:mratcliffe] 2012-08-13 03:47:18 PDT
Full list of booleans with default values:
- jsb/preserveNewlines
- jsb/jslintHappy
- jsb/spaceBeforeConditional
- jsb/unescapeStrings
- restart/nocache
- screenshot/fullpage

The problem is that e.g. jsb is a well known beautifier and people are used to the params as they are, with boolean defaults being either true or false.

I could simply use the strings "true" or "false", but need to speak with Joe about this.
Comment 3 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-08-13 05:46:14 PDT
(I made a typo above, the defaultValue of a boolean parameter is false not true)

There has to be a default one way or the other or it would be really confusing:
>> cmd --this --that

Where this and that had different defaults - one would be turning a feature on and the other would be turning it off.

It seems sensible for me for a switch to be switching something 'on' and that it's off by default.

How about having noSpaceBeforeConditional and dontPreserveNewlines ?
Comment 4 Joe Walker [:jwalker] (needinfo me or ping on irc) 2012-08-27 05:23:24 PDT
The commands now have the right sense, and we're doing more work on JSB in a separate bug.

Note You need to log in before you can comment on or make changes to this bug.