Resolution of Popcap games served to b2g build of gecko increased (due to UA change?)

RESOLVED DUPLICATE of bug 785647

Status

()

Core
General
RESOLVED DUPLICATE of bug 785647
5 years ago
2 years ago

People

(Reporter: dzbarsky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
On b2g devices, http://people.mozilla.org/~mwoodrow/dz-broke-transforms.html used to have the game scaled to fit the iframe.  It is now too big.  This may be related to us changing the UA string.
In a gecko build from a week ago or so, the games were served at 320x480.  Now they're served at something like 4x those dimensions.  Changing the UA string seems a likely cause of this.

We may need to morph this into an evang bug.
Summary: Popcap games aren't scaled to iframe. → Resolution of Popcap games served to b2g build of gecko increased (due to UA change?)
Note that we have since update the CSS in Gaia:

https://github.com/mozilla-b2g/gaia/issues/3325
We're working around this, but the games are drawing 16x more pixels than they were before, so performance has gone down the toilet.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 785647
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.