When I download Firefox I can only get the Russian version, not USA

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: campernj1, Unassigned)

Tracking

14 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

I had deleted Firefox because I was having problems, and re-downloaded saving my add-ons.


Actual results:

W hen I re-downloaded it I can only get the Russian version with Яндекс as the search engine instead of Google.


Expected results:

I should have been able to download the English/United States [en-us] version. It is listed as my language in options, however my start page is still  in Russian with their search engine, not Google
Please contact the support under http://support.mozilla.org
bugzilla is the developer area of mozilla.org and support questions are not answered here.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.