Closed Bug 780301 Opened 9 years ago Closed 9 years ago

Keep text selection in editable elements inside those editable elements

Categories

(Firefox for Android Graveyard :: Text Selection, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox17 affected, fennec+)

RESOLVED DUPLICATE of bug 667243
Tracking Status
firefox17 --- affected
fennec + ---

People

(Reporter: Margaret, Assigned: wesj)

References

Details

This is a follow-up to bug 765079 comment 9.

Dragging a selection that originated inside an editable element outside of it will run into problems because we use different selection APIs for editable elements. I imagine the same problem might happen if a selection that started outside an editable element moved into one.
We should address this before shipping bug 765079.
tracking-fennec: --- → ?
Blocks: 781182
Why isn't this a dup of bug 781182
I filed this bug about making sure we don't start selecting text outside the input boxes (and also don't start selecting text inside them if we were selecting normal text on the page) because text selection actually breaks in these cases (we end up using the wrong selection APIs).

If I understand Aaron correctly, he morphed bug 781182 to be about going one step further and actually scrolling the input boxes if you try to select text past the edge of the input box.

So basically, this bug is about not getting into a busted text selection state; bug 781182 is about enhancing text selection in input boxes.
tracking-fennec: ? → 17+
Assignee: nobody → wjohnston
tracking-fennec: 17+ → 18+
Wes - Any chance you can take a look at this?
Flags: needinfo?(wjohnston)
Brian - Is this fixed now?
Flags: needinfo?(wjohnston) → needinfo?(bnicholson)
Nope, bug 795045 is just for the cursor thumb, which is independent from the text selection code.
Flags: needinfo?(bnicholson)
bumping to a plus since we've shipped this feature in 2 release now
tracking-fennec: 18+ → +
This is fixed by the patch in bug 667243.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 667243
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.