Closed Bug 780356 Opened 9 years ago Closed 6 years ago

Share function is a bit outdated (digg, myspace, no reddit)

Categories

(addons.mozilla.org Graveyard :: Public Pages, enhancement, P5)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: steve, Assigned: pemmasanikrish)

References

Details

(Whiteboard: [contribute])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.0) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.60 Safari/537.1

Steps to reproduce:

visited the page for my addon


Actual results:

this is really minor, but just something I pointed out on the Jetpack IRC and it was suggested I file a bug here...

the "share this addon" feature has support for outdated / rarely used sites (these days) like Digg, MySpace and FriendFeed, and none for Reddit


Expected results:

nothing is "wrong" per se, just a suggestion to add reddit, perhaps remove antequated sites unless they're still being used with some frequency.
Severity: normal → enhancement
Priority: -- → P5
Whiteboard: [contribute]
Duplicate of this bug: 908975
Status: UNCONFIRMED → NEW
Ever confirmed: true
What is... "FriendFeed"?
I would like to take this bug. Could someone please advise what sharing services should be added or removed and assign the bug to me?

Providing additional information below for my own (or others') reference.

File to be updated: https://github.com/mozilla/olympia/blob/master/apps/sharing/__init__.py

reddit submit API: http://www.reddit.com/dev/api#POST_api_submit
https://github.com/reddit/reddit/wiki/API:-submit

Properly formed GET request: http://www.reddit.com/submit?url={url}&title={title}&kind=link
Duplicate of this bug: 1162280
(In reply to Jason Ellis from comment #4)
> I would like to take this bug. Could someone please advise what sharing
> services should be added or removed and assign the bug to me?

In this order, top to bottom:
Facebook
Twitter
Google+
Reddit
Tumblr

Let us know if you have any questions. Thanks!
Assignee: nobody → jason.c.ellis
Hi Jason,

If you're still interested in working on this, I can give you whatever help you need. Just ping me on irc://irc.mozilla.org/amo (nick: John-Galt) whenever you have a chance.

Thanks!
Patched the Bug 780356 (Share function is a bit outdated )
 Added new features and removed old now these are present:
 Facebook
 Twitter
 Google+
 Reddit
 Tumblr
Verify the patch submitted.
Flags: needinfo?(jorge)
Please send a Pull Request instead. The review might take a while since we're low on developers and they're fairly busy.
Assignee: jason.c.ellis → pemmasanikrish
Flags: needinfo?(jorge)
Fixed in https://github.com/mozilla/olympia/commit/8424d1cae001316b840c748aea6bf6b3eb8cdfac, thanks a lot!
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.