Bad display of the page (header)

RESOLVED DUPLICATE of bug 20575

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 20575
17 years ago
17 years ago

People

(Reporter: Cedric Berger, Assigned: asa)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.8.1+)
Gecko/20010426
BuildID:    2001042615

This page looks *very* wrong in Mozilla. Other browsers display it correctly.

Reproducible: Always
Steps to Reproduce:
1. go to http://java.sun.com/aboutJava/communityprocess/?frontpage-spotlight
2.
3.

Comment 1

17 years ago
OS/All, seen on Linux, over to Layout. Need to investigate further before
confirming.
Component: Browser-General → Layout
OS: Windows NT → All

Comment 2

17 years ago
At about line 243, there is
<IMG SRC="images/jcp.cover.gif" BORDER="0" HEIGHT=125" WIDTH="260"
ALT="Java Community Process(SM)" ALIGN="LEFT">

Note the missing double quote at HEIGHT=. Could this be the cause?

Comment 3

17 years ago
Actually, take a look at the source code, and you'll see that they've put a
table within the main content cell:

<table BORDER="0" CELLPADDING="0" CELLSPACING="0" WIDTH="100%">
<tr>
<td ALIGN="RIGHT"><img SRC="/images/banners/stripelt.gif" WIDTH=6 HEIGHT=14
ALT=""></td>
<td WIDTH="100%"> <--- ****** SEE THAT ?
<table BORDER="0" CELLPADDING="0" CELLSPACING="0" WIDTH="100%">
<tr><td BGCOLOR="#CC9966" WIDTH="100%"><img SRC="/images/pixel.gif" HEIGHT=2
WIDTH=1 ALT=""></td></tr>
<tr><td><img SRC="/images/pixel.gif" HEIGHT=2 WIDTH=1 ALT=""></td></tr>
<tr><td BGCOLOR="#CC9966"><img SRC="/images/pixel.gif" HEIGHT=2 WIDTH=1
ALT=""></td></tr>
<tr><td><img SRC="/images/pixel.gif" HEIGHT=2 WIDTH=1 ALT=""></td></tr>
<tr><td BGCOLOR="#CC9966"><img SRC="/images/pixel.gif" HEIGHT=2 WIDTH=1
ALT=""></td></tr>
<tr><td><img SRC="/images/pixel.gif" HEIGHT=2 WIDTH=1 ALT=""></td></tr>
<tr><td BGCOLOR="#CC9966"><img SRC="/images/pixel.gif" HEIGHT=2 WIDTH=1
ALT=""></td></tr>
</table></td>
<td ALIGN="LEFT"><img SRC="/images/banners/stripert.gif" WIDTH=6 HEIGHT=14
ALT=""></td>

-- Now comes the search box table --


<td><table BORDER="0" CELLPADDING="0" CELLSPACING="0">
<tr><td VALIGN="middle"><a HREF="/a-z/"><img SRC="/images/banners/azindex.gif"
WIDTH=72 HEIGHT=11 ALT="A-Z Index" BORDER="0"></a></td>
<td VALIGN="middle"><font FACE="Helvetica" SIZE="1"><input TYPE="text" SIZE="15"
MAXLENGTH="2033" NAME=qt></font></td>
<td VALIGN="middle"><input TYPE="image" SRC="/images/banners/search.button.gif"
value="search" name="search" WIDTH=55 HEIGHT=14 ALT="Search the Site"
BORDER="0"></td></tr></table></td>
</tr>
</table></form>

The point is that I think Mozilla is interpreting the html correctly, but the
designers didn't intend for it to be displayed this way. I might testcase this,
but it's rather a complex page and thus something in there could be wrong which
is causing us to fall over.

I believe the parser protects us againsr missing quotes in element attribute
properties.

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 20575 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.