Implement FPS counter on DirectX/Windows

RESOLVED DUPLICATE of bug 874781

Status

()

enhancement
RESOLVED DUPLICATE of bug 874781
7 years ago
6 years ago

People

(Reporter: helder.magalhaes, Assigned: jgilbert)

Tracking

(Blocks 1 bug)

Trunk
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [games:p3])

Reporter

Description

7 years ago
Bug 612407 has added support for an FPS counter, which apparently is only available for OpenGL renderers. Bug 612407 comment 22 states that "if you need D3D or something like that, we should add related implementation for D3D backend"

Given this is a highly desirable feature for measuring drawing performance, I'm adding this feature request for implementing the feature of the the DirectX-based backend.
Whiteboard: [games:p?]
Jeff mentioned he was interested in this. Ideally the FPS counter should be backend agnostic.
Whiteboard: [games:p?] → [games:p3]
Assignee

Updated

7 years ago
Assignee: nobody → jgilbert
This is being done in bug 874781.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 874781
You need to log in before you can comment on or make changes to this bug.