Firefox renders the PNG with improper colors(blue instead of brown)

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
2 months ago

People

(Reporter: alice0775, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 649154 [details]
png

This is spun off from Bug 780514 Problem #1.

Firefox renders the PNG with improper colors(blue instead of brown)


Last Good:
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1b1pre) Gecko/20080911105329 Shiretoko/3.1b1pre ID:20080911105329
First Bad:
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1b1pre) Gecko/20080912031847 Shiretoko/3.1b1pre ID:20080912031847

Triggered by
Bug 418538 -Enable color management support by default 

It works if I set gfx.color_management.mode to 0
(Reporter)

Comment 1

6 years ago
Safari 5 for windows shows as blown color.

Comment 3

6 years ago
I can confirm this occurs on Firefox 13.0.1 on Mac OS X 10.7.4.

In Photoshop CS6 I'm seeing the encoded RGB values in the PNG are 235, 224, 213, and is displayed as blue-gray when honoring the embedded ICC profile "Samsung - Natural Color Pro 1.0 ICM.icc" So there is parity between Photoshop and Firefox.

I believe the issue is that the profile defines the PCS illuminant as D50 (correct), it defines the wtpt tag as D65 (ambiguous, possibly correct for v2, not correct for v4 spec profiles), but the RGB primaries are not adapted for D50, rather they are D65 primaries. So I believe this is a case of improper adaptation of the primaries in the embedded profile, not a bug. But I'll do some digging around, and report back if a correction is warranted.
Chrome Canary also displays it as blue. Chrome has supported color management since version 22.

Comment 5

6 years ago
Confirmed. This is not a Firefox bug. It's a bug in the Samsung profile that's embedded in the PNG. The RGB primaries are unadapted from the D65 white point, and the ICC spec that this profile purports to comply with requires relative XYZ values, adapted to the PCS illuminant which is D50.

Samsung should be advised.

How was this PNG produced with the embedded profile? If there are applications that embed display profiles, the developer should be advised against doing this. They should instead embed an ICC profile for a common color space such as sRGB, Adobe RGB, ECI RGB, or something along those lines, rather than embedding manufacturer display profiles.
andras.fuchs@gmail.com is the original reporter and he should be able to answer your question
(Reporter)

Updated

2 months ago
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.