pdf font rendering bug

REOPENED
Unassigned

Status

()

REOPENED
6 years ago
6 years ago

People

(Reporter: marcel.dejean, Unassigned)

Tracking

19 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-rendering][pdf-d-font-windows], URL)

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
This PDF renders completely wrong.

http://katalog.we-online.de/kataloge/eisos/media/pdf/7447471104.pdf
Renders wrong only on Windows with hardware acceleration enabled.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

6 years ago
Whiteboard: [pdfjs-c-rendering][pdf-d-font-windows]

Comment 2

6 years ago
I can see crippled text here on Linux x64 FF 17.

Comment 3

6 years ago
Is it OK now on Windows?
Flags: needinfo?(Doodle777)
(Reporter)

Comment 4

6 years ago
Created attachment 719459 [details]
image of bug on windows

The text is still messed up :/
Flags: needinfo?(Doodle777)

Comment 5

6 years ago
(In reply to Marcel Dejean from comment #4)
> The text is still messed up :/
Not for me even in Firefox 19.

Have you installed the latest Windows updates including KB2670838?
(Reporter)

Comment 6

6 years ago
The PDF displays correctly after installing KB2670838.

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Comment 7

6 years ago
This bug appears to persist for FF 19 on Linux.

This may not be a font problem cause German sites appears ok.

Comment 8

6 years ago
Created attachment 721715 [details]
Buggy rendering.

Comment 9

6 years ago
(In reply to dE from comment #7) 
> This bug appears to persist for FF 19 on Linux.
What are the errors in the web console?
What is your graphics section of about:support?
Flags: needinfo?(de.techno)
OS: Windows 7 → Linux
Summary: pdf rendering bug → pdf font rendering bug
Version: 14 Branch → 19 Branch

Updated

6 years ago
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Looks like it's popular on Linux to disable web fonts (https://support.mozilla.org/en-US/kb/change-fonts-and-colors-websites-use#w_custom-fonts). dE, could you try to use new/empty profile?

Comment 11

6 years ago
Created attachment 726164 [details]
CSS related errors.

Oh, I forgot to report!
Flags: needinfo?(de.techno)

Comment 12

6 years ago
Tried as a new user.

Problem persists.

Intel Open Source Technology Center -- Mesa DRI Intel(R) Sandybridge Desktop 
3.0 Mesa 9.0.1
GPU Accelerated:Windows1/1 OpenGL
Vendor ID:Intel Open Source Technology Center
You need to log in before you can comment on or make changes to this bug.