Intermittent crash in Talos, test_nodereplacechildnodename.html, test_nodeprocessinginstructionnodename.html, test_namednodemapsetnameditemwithnewvalue.html, browser_tabview_bug587990.js, test_HTMLDocument26.html [@ js::SourceCompressorThread::threadLoop]

RESOLVED DUPLICATE of bug 779118

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 779118
5 years ago
5 years ago

People

(Reporter: emorley, Unassigned)

Tracking

({crash, intermittent-failure})

Trunk
x86_64
Mac OS X
crash, intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [red][js:t], crash signature)

(Reporter)

Description

5 years ago
Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound talos tpn on 2012-08-03 15:04:06 PDT for push c2917d3532c8

slave: talos-r4-snow-053

https://tbpl.mozilla.org/php/getParsedLog.php?id=14110102&tree=Mozilla-Inbound

{
NOISE: MOZ_EVENT_TRACE sample 1344032564113 238
NOISE: MOZ_EVENT_TRACE sample 1344032564177 63
NOISE: Cycle 1(10): loaded http://localhost/page_load_test/tp5n/uol.com.br/www.uol.com.br/index.html (next: http://localhost/page_load_test/tp5n/cnet.com/www.cnet.com/index.html)
NOISE: MOZ_EVENT_TRACE sample 1344032564344 166
NOISE: NOTE: child process received `Goodbye', closing down
NOISE: RSS: Main: 172683264
NOISE: 
NOISE: 
NOISE: __FAILbrowser non-zero return code (256)__FAIL
NOISE: Found crashdump: /var/folders/Hs/HsDn6a9SG8idoIya6p9mtE+++TI/-Tmp-/tmpI38k0v/profile/minidumps/BCB62AA9-6A72-4D1E-834E-46C19C56BEA7.dmp
Operating system: Mac OS X
                  10.6.8 10K549
CPU: amd64
     family 6 model 23 stepping 10
     2 CPUs

Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash address: 0x8

Thread 7 (crashed)
 0  XUL!js::SourceCompressorThread::threadLoop [jsscript.cpp : 1032 + 0x4]
    rbx = 0x16d85e18   r12 = 0x19fc0de0   r13 = 0x19fc0de8   r14 = 0x18280e38
    r15 = 0x00000248   rip = 0x024c457b   rsp = 0x18280e30   rbp = 0x18280ee0
}
Looks like this happened again:
https://tbpl.mozilla.org/php/getParsedLog.php?id=14156619&tree=Mozilla-Inbound
(Reporter)

Comment 2

5 years ago
Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound talos tpn on 2012-08-04 22:50:35 PDT for push 0e213ba77dca

slave: talos-r4-snow-02

During:
media.photobucket.com/image/funny%20gif/findstuff22/Best%20Images/Funny/funny-gif1.jpg@o=1.html

https://tbpl.mozilla.org/php/getParsedLog.php?id=14138139&tree=Mozilla-Inbound
Summary: Intermittent talos tp5n crash on www.uol.com.br/index.html [@ js::SourceCompressorThread::threadLoop] → Intermittent talos tp5n crash on www.uol.com.br/index.html, media.photobucket.com/image/funny%20gif/.... [@ js::SourceCompressorThread::threadLoop]
(Reporter)

Comment 3

5 years ago
Rev4 MacOSX Lion 10.7 mozilla-inbound talos tpn on 2012-08-07 01:47:29 PDT for push 8eb11b30a8f2

slave: talos-r4-lion-017

https://tbpl.mozilla.org/php/getParsedLog.php?id=14183589&tree=Mozilla-Inbound
(Reporter)

Comment 4

5 years ago
Rev4 MacOSX Lion 10.7 mozilla-central opt test mochitests-3/5 on 2012-08-07 03:53:26 PDT for push 1bbc0b65dffb

slave: talos-r4-lion-024

https://tbpl.mozilla.org/php/getParsedLog.php?id=14185964&tree=Firefox

{
8049 INFO TEST-START | /tests/dom/tests/mochitest/dom-level1-core/test_nodeprocessinginstructionnodename.html
NOTE: child process received `Goodbye', closing down
TEST-UNEXPECTED-FAIL | /tests/dom/tests/mochitest/dom-level1-core/test_nodeprocessinginstructionnodename.html | Exited with code 1 during test run
INFO | automation.py | Application ran for: 0:03:47.041716
INFO | automation.py | Reading PID log: /var/folders/qd/srwd5f710sj0fcl9z464lkj00000gn/T/tmpw8fh_apidlog
Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-macosx64/1344333918/firefox-17.0a1.en-US.mac.crashreporter-symbols.zip
PROCESS-CRASH | /tests/dom/tests/mochitest/dom-level1-core/test_nodeprocessinginstructionnodename.html | application crashed (minidump found)
Crash dump filename: /var/folders/qd/srwd5f710sj0fcl9z464lkj00000gn/T/tmpIB0TFP/minidumps/0342BC69-3D7D-4FD5-9A80-ED632D431F1E.dmp
Operating system: Mac OS X
                  10.7.2 11C74
CPU: amd64
     family 6 model 23 stepping 10
     2 CPUs

Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
Crash address: 0x8

Thread 7 (crashed)
 0  XUL!js::SourceCompressorThread::threadLoop [jsscript.cpp : 1034 + 0x4]
    rbx = 0x06622e18   r12 = 0x1a829ae0   r13 = 0x1a829ae8   r14 = 0x091cde38
    r15 = 0x00011086   rip = 0x024ca24b   rsp = 0x091cde30   rbp = 0x091cdee0
    Found by: given as instruction pointer in context
 1  libsystem_c.dylib + 0x50f7d
    rip = 0x8d7e5f7e   rsp = 0x091cde38
    Found by: stack scanning
 2  XUL + 0x150450f
    rip = 0x02504510   rsp = 0x091cde80
    Found by: stack scanning
 3  XUL!zlib_alloc [mozilla-central::1bbc0b65dffb : 157 + 0x8]
    rip = 0x02504520   rsp = 0x091cde88
    Found by: stack scanning
 4  libnspr4.dylib + 0x1de2f
    rip = 0x00070e30   rsp = 0x091cdee0
    Found by: stack scanning
 5  libnspr4.dylib!_pt_root [ptthread.c : 156 + 0x6]
    rip = 0x00070efb   rsp = 0x091cdef0
    Found by: stack scanning
 6  libsystem_c.dylib + 0x4e8be
    rip = 0x8d7e38bf   rsp = 0x091cdf20
    Found by: stack scanning
 7  libsystem_c.dylib + 0x51b74
    rip = 0x8d7e6b75   rsp = 0x091cdf60
    Found by: stack scanning
}
Summary: Intermittent talos tp5n crash on www.uol.com.br/index.html, media.photobucket.com/image/funny%20gif/.... [@ js::SourceCompressorThread::threadLoop] → Intermittent crash on www.uol.com.br/index.html, media.photobucket.com/image/funny%20gif/...., test_nodeprocessinginstructionnodename.html [@ js::SourceCompressorThread::threadLoop]
Depends on: 776475
https://tbpl.mozilla.org/php/getParsedLog.php?id=14254524&tree=Firefox
(Reporter)

Comment 6

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=14296337&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=14458946&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=14485666&tree=Mozilla-Inbound
(Reporter)

Comment 9

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=14552699&tree=Mozilla-Inbound
(Reporter)

Comment 10

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=14590650&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=14604871&tree=Birch
https://tbpl.mozilla.org/php/getParsedLog.php?id=14581707&tree=Try
https://tbpl.mozilla.org/php/getParsedLog.php?id=14653283&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=14716171&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=14760410&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=14764058&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=14791687&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=14824893&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=14862018&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=14879652&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=14962821&tree=Mozilla-Inbound
Summary: Intermittent crash on www.uol.com.br/index.html, media.photobucket.com/image/funny%20gif/...., test_nodeprocessinginstructionnodename.html [@ js::SourceCompressorThread::threadLoop] → Intermittent crash in Talos, test_nodeprocessinginstructionnodename.html, test_namednodemapsetnameditemwithnewvalue.html [@ js::SourceCompressorThread::threadLoop]
https://tbpl.mozilla.org/php/getParsedLog.php?id=14989478&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=15014138&tree=Ionmonkey
https://tbpl.mozilla.org/php/getParsedLog.php?id=15026096&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=15034889&tree=Mozilla-Inbound
Summary: Intermittent crash in Talos, test_nodeprocessinginstructionnodename.html, test_namednodemapsetnameditemwithnewvalue.html [@ js::SourceCompressorThread::threadLoop] → Intermittent crash in Talos, test_nodeprocessinginstructionnodename.html, test_namednodemapsetnameditemwithnewvalue.html, browser_tabview_bug587990.js [@ js::SourceCompressorThread::threadLoop]
(Reporter)

Comment 26

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=15040887&tree=Mozilla-Inbound
Whiteboard: [orange][red] → [orange][red][js:t]
https://tbpl.mozilla.org/php/getParsedLog.php?id=15076502&tree=Try
Summary: Intermittent crash in Talos, test_nodeprocessinginstructionnodename.html, test_namednodemapsetnameditemwithnewvalue.html, browser_tabview_bug587990.js [@ js::SourceCompressorThread::threadLoop] → Intermittent crash in Talos, test_nodereplacechildnodename.html, test_nodeprocessinginstructionnodename.html, test_namednodemapsetnameditemwithnewvalue.html, browser_tabview_bug587990.js [@ js::SourceCompressorThread::threadLoop]
https://tbpl.mozilla.org/php/getParsedLog.php?id=15102352&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=15104456&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=15108393&tree=Mozilla-Inbound
(Reporter)

Comment 31

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=15126665&tree=Firefox
Summary: Intermittent crash in Talos, test_nodereplacechildnodename.html, test_nodeprocessinginstructionnodename.html, test_namednodemapsetnameditemwithnewvalue.html, browser_tabview_bug587990.js [@ js::SourceCompressorThread::threadLoop] → Intermittent crash in Talos, test_nodereplacechildnodename.html, test_nodeprocessinginstructionnodename.html, test_namednodemapsetnameditemwithnewvalue.html, browser_tabview_bug587990.js test_HTMLDocument26.html [@ js::SourceCompressorThread::threadLoop]
https://tbpl.mozilla.org/php/getParsedLog.php?id=15222183&tree=Firefox
(Reporter)

Comment 33

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=15282127&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=15391845&tree=Cedar
https://tbpl.mozilla.org/php/getParsedLog.php?id=15445549&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=15450892&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=15474940&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=15536891&tree=Try
https://tbpl.mozilla.org/php/getParsedLog.php?id=15575943&tree=Firefox
https://tbpl.mozilla.org/php/getParsedLog.php?id=15604384&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=15634921&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=15688544&tree=Try
https://tbpl.mozilla.org/php/getParsedLog.php?id=15960322&tree=Mozilla-Inbound
https://tbpl.mozilla.org/php/getParsedLog.php?id=16005853&tree=Mozilla-Inbound
(Reporter)

Comment 45

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=16020298&tree=Mozilla-Inbound
(Reporter)

Updated

5 years ago
Blocks: 800863
https://tbpl.mozilla.org/php/getParsedLog.php?id=16078202&tree=Mozilla-Aurora
https://tbpl.mozilla.org/php/getParsedLog.php?id=16091305&tree=Mozilla-Aurora

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 779118
Keywords: intermittent-failure
Whiteboard: [orange][red][js:t] → [red][js:t]
You need to log in before you can comment on or make changes to this bug.