Closed Bug 780683 Opened 12 years ago Closed 12 years ago

Tags are duplicated in buglists if a search criteria involves a user field external to the 'bugs' table

Categories

(Bugzilla :: Query/Bug List, defect)

4.3.2
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Bugzilla 4.4

People

(Reporter: LpSolit, Assigned: LpSolit)

References

Details

Attachments

(1 file)

Search for bugs which have some user as attachment creator, and display the tags column in the buglist. Tags are duplicated in a way which seems proportional to the number of attachments in the bug.

I tried with other user fields whose data is stored outside the 'bugs' table, such as the commenter or the flag setter/requestee, and in all cases are tags duplicated.

I wonder if the root cause is the same as for bug 780053.
Flags: blocking4.4+
Attached patch patch, v1Splinter Review
I forgot to add DISTINCT, as we do for flags.
Assignee: query-and-buglist → LpSolit
Status: NEW → ASSIGNED
Attachment #649346 - Flags: review?(timello)
Attachment #649346 - Flags: review?(dkl)
Comment on attachment 649346 [details] [diff] [review]
patch, v1

Review of attachment 649346 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good and works as expected. r=dkl
Attachment #649346 - Flags: review?(dkl) → review+
Flags: approval+
Attachment #649346 - Flags: review?(timello)
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified Bugzilla/Search.pm
Committed revision 8333.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: