Email newsletter signup form for whatsnew pages on Bedrock

RESOLVED DUPLICATE of bug 771314

Status

www.mozilla.org
General
RESOLVED DUPLICATE of bug 771314
5 years ago
5 years ago

People

(Reporter: Jessilyn Davis (Maternity Leave), Assigned: sgarrity)

Tracking

unspecified
Future
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=email p=2)

(Reporter)

Description

5 years ago
Prompted by bug: 775406 "please add email signup back to the What's New page"
https://bugzilla.mozilla.org/show_bug.cgi?id=775406

The email signup form on the what's new page should operate like the signup forms on FF13's What's new page (before the bedrock update & FF14's release) and should be localized across all locales.

Email newsletter signup forms should have these fields:

Email Address
Language  (choices: EN, FR, DE, PT, ES)
Country
Email Format
Privacy Policy

When a non-EN language is chosen, basket should trigger a double-opt in process like the newsletter signup form found here: 

https://www.mozilla.org/fr/newsletter/

Timing: It would be great to have this fixed as soon as possible as without the localized versions of the signup form on the whatsnew page, our weekly l10n newsletter signups have decreased by 50%

Please let me know the timeline for implementation and if you have any questions.

Thanks!

Jess
Jess, just to clarify requirements:

- we will add the languages in the dropdown, outlined above.
- add logic for specific behavior based on language chosen in the dropdown (based on /fr newsletter).

Out of scope for this bug: translating signup form itself.

We'll get this assigned and prioritized.
Whiteboard: u=user c=email p=2
Target Milestone: --- → Future
(Reporter)

Comment 2

5 years ago
(In reply to Mike Alexis [:malexis] from comment #1)
> Jess, just to clarify requirements:
> 
> - we will add the languages in the dropdown, outlined above.
Correct - and add "Country" drop down too please

> - add logic for specific behavior based on language chosen in the dropdown
> (based on /fr newsletter).
> 
Correct

> Out of scope for this bug: translating signup form itself.
> 
Makes sense - this would be part of the l10n localization strings for this page. (These strings should already be localized as it was localized for 13+ locales on the FF13 whats new page (pre-bedrock). PascalC may know where these strings are stored/know the logic for displaying the email signup block if it is localized - and if it's not localized it's hidden for that locale.)

> We'll get this assigned and prioritized.

Thanks!

Comment 3

5 years ago
Thanks Mike. +1 for making this happen as soon as we can.

Updated

5 years ago
Whiteboard: u=user c=email p=2 → [sp-2012-08-14] u=user c=email p=2
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org

Updated

5 years ago
Assignee: chrismore.bugzilla → steven
Whiteboard: [sp-2012-08-14] u=user c=email p=2 → u=user c=email p=2
The requirements here are for all en-US newsletter sign up forms across Mozilla.org so closing this out and we'll track the work in bug#771314
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 771314
You need to log in before you can comment on or make changes to this bug.