Cannot watch many different videos on HTML 5 YouTube (WebM format)

RESOLVED DUPLICATE of bug 781204

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 781204
5 years ago
5 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Reporter)

Description

5 years ago
YouTube on Firefox OS serves us a desktop site. When trying to view most video content, YouTube tries to get flash content and serve it to Firefox OS. Flash content is not supported on Firefox OS, so many videos appear broken to the end user. This is a terrible user experience and on the top of all of this, YouTube happens to be a top site for Brazil. We need a strategy to get around this issue, whether it would be evangelism or other ideas that could be used to solve this problem.
(Reporter)

Comment 1

5 years ago
Nominating for basecamp - we need to figure out what to do here.

Note - this isn't just an evangelism issue, as youtube.com/html5 content isn't working for me either. Possible ways to go about this:

- Inject a force on youtube to serve us the html5 trial or evangelize them to do so
- Figure out why html5 content isn't running on youtube
blocking-basecamp: --- → ?
(Reporter)

Updated

5 years ago
Summary: Cannot watch many different videos on YouTube due to overuse of demand for flash content → Cannot watch many different videos on YouTube due to typical use of flash content & html5 content not starting up either
(Reporter)

Updated

5 years ago
Blocks: 759982
What is the H.264 software encoding story for B2G?
(Reporter)

Comment 3

5 years ago
(In reply to Aaron Train [:aaronmt] from comment #2)
> What is the H.264 software encoding story for B2G?

It's supported on Firefox OS I believe.
Getting youtube to serve b2g the html5 content is an evang problem.

For the html5 content not working, we need to know
 - what format video are they serving
 - what's going wrong in gecko

A run-of-the-mill bug is possible.
(In reply to Chris Jones [:cjones] [:warhammer] from comment #4)
> Getting youtube to serve b2g the html5 content is an evang problem.

(But note that if we can't effect server-side changes, there are some extremely dirty hacks we can add on the client side.)
(Reporter)

Comment 6

5 years ago
Putting qawanted and assigning to me to investigate. I'll dig into this.
Keywords: qawanted
QA Contact: jsmith
(Reporter)

Comment 7

5 years ago
Here's one example that doesn't load on the phone (with a decent internet connection):

http://www.youtube.com/watch?v=wnG-rFFpP8A

Works fine on desktop to confirm the video runs. Debug info below. Looks like the video is webm.

{"b":[],"e":[],"i":["915507","907217","922401","919804","920704","912806","906055","924500","906831","925701","924700","911406","913547","904721","920706","907344","912706","900816","902518","909414"],"Fb":"//s.youtube.com/s","Rj":false,"Sj":0,"zn":565,"Bn":511,"ka":565,"Cn":555,"Hb":100,"Uj":false,"eventLabel":"detailpage","yn":"en_US","Tj":"yt","A":{"width":640,"height":390},"En":null,"referrer":"http://www.youtube.com/results?search_query=NASA+Lands+Car-Size+Rover+Beside+Martian+Mountain&oq=NASA&gs_l=youtube.1.0.35i39j0l9.2144.2938.0.3663.4.4.0.0.0.0.110.349.3j1.4.0...0.0...1ac.bvva5cz5pTg","Hn":"US","H":{"width":1920,"height":1080},"In":"NASA Lands Car-Size Rover Beside Martian Mountai","pa":24,"va":"m","Gb":8767,"R":{"width":640,"height":360},"Kn":"ra1yX_gpC7f_LHE2QmbzSOl5RvErM7HzU","Kb":"html5_watch","format":{"a":"http://o-o---preferred---comcast-sjc2---v3---lscache7.c.youtube.com/videoplayback?upn=tzLIW3-BKmY&sparams=cp%2Cid%2Cip%2Cipbits%2Citag%2Cratebypass%2Csource%2Cupn%2Cexpire&fexp=915507%2C907217%2C922401%2C919804%2C920704%2C912806%2C906055%2C924500%2C906831%2C925701%2C924700%2C911406%2C913547%2C904721%2C920706%2C907344%2C912706%2C900816%2C902518%2C909414&ms=au&itag=43&ipbits=8&signature=1C3F376F12C94987FE9A2EA8B51299FC0AD2E4B4.CD61DBE76DC94CD7D490A9816422986C166A5ABB&mv=m&sver=3&mt=1344319390&ratebypass=yes&source=youtube&expire=1344345121&key=yt1&ip=98.248.43.172&cp=U0hTSVNPU19HS0NOM19LSVdCOjhSMjFxd0Rmb1hK&id=c271beac51693fc0&newshard=yes","$f":"video/webm; codecs=\"vp8.0, vorbis\"","Qb":"medium","Pa":"43","e":false,"size":{"width":640,"height":360},"b":928},"Vj":false,"ia":0,"ja":0,"ua":"AATGpsDAXQPw6Wk4","Wj":true,"B":"wnG-rFFpP8A","Aa":{"width":640,"height":360},"Jb":20.433,"u":561.763,"debug_videoId":"wnG-rFFpP8A","debug_playbackQuality":"medium","debug_date":"Mon Aug 06 2012 23:03:49 GMT-0700 (Pacific Daylight Time)"}
(Reporter)

Comment 8

5 years ago
I'm going to use this bug to track the gecko problems. I'll file a separate bug for the evangelism piece to convince YouTube to serve us HTML 5 content, not flash content.
Component: General → Video/Audio
Keywords: qawanted
Product: Boot2Gecko → Core
Summary: Cannot watch many different videos on YouTube due to typical use of flash content & html5 content not starting up either → Cannot watch many different videos on HTML 5 YouTube (WebM format)
(Reporter)

Updated

5 years ago
Version: unspecified → Trunk
(Reporter)

Comment 9

5 years ago
For comment 7 btw - that debug info comes from Desktop, not the Otoro device. Just used that determine it was WebM content.
(Reporter)

Comment 10

5 years ago
Looks like WebM videos generally are not working at all. Duping on the reduced bug (bug 781204) for simplicity.
Status: NEW → RESOLVED
blocking-basecamp: ? → ---
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 781204
Marking basecamp+ just so we don't regress on YouTube specifically.
blocking-basecamp: --- → +
You need to log in before you can comment on or make changes to this bug.