Last Comment Bug 780825 - B2G RIL: Read code scheme 0x81, 0x82 UCS2 string on ICC
: B2G RIL: Read code scheme 0x81, 0x82 UCS2 string on ICC
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: ARM Gonk (Firefox OS)
: -- normal (vote)
: mozilla17
Assigned To: Yoshi Huang[:allstars.chh]
:
: Andrew Overholt [:overholt]
Mentors:
Depends on: 779885
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-06 23:40 PDT by Yoshi Huang[:allstars.chh]
Modified: 2012-08-10 01:56 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
WID - Patch to read UCS2 on ICC (3.78 KB, patch)
2012-08-08 02:32 PDT, Yoshi Huang[:allstars.chh]
no flags Details | Diff | Splinter Review
Part 1: Read 0x81 and 0x82 UCS2 String on UICC (3.77 KB, patch)
2012-08-09 00:08 PDT, Yoshi Huang[:allstars.chh]
vicamo: review+
Details | Diff | Splinter Review
Part 2: xpcshell tests (1.97 KB, patch)
2012-08-09 00:10 PDT, Yoshi Huang[:allstars.chh]
no flags Details | Diff | Splinter Review
Part 2: xpcshell tests v2 (1.44 KB, patch)
2012-08-09 03:18 PDT, Yoshi Huang[:allstars.chh]
no flags Details | Diff | Splinter Review
Part 2: xpcshell tests v3 (1.44 KB, patch)
2012-08-09 20:09 PDT, Yoshi Huang[:allstars.chh]
vicamo: review+
Details | Diff | Splinter Review
Part 1: Read 0x81 and 0x82 UCS2 String on UICC (3.78 KB, patch)
2012-08-09 21:11 PDT, Yoshi Huang[:allstars.chh]
no flags Details | Diff | Splinter Review
Part 2: xpcshell tests v3 (1.44 KB, patch)
2012-08-09 21:12 PDT, Yoshi Huang[:allstars.chh]
no flags Details | Diff | Splinter Review

Description Yoshi Huang[:allstars.chh] 2012-08-06 23:40:19 PDT
From TS 102.221, Annex A 
"UCS2 coding of Alpha fields for files residing on the UICC":

There are 3 coding schemes for UCS2 string on the UICC.

The first one and most common one(0x80) should be implemented in Bug 779885,
but the others( 0x81 and 0x82) are quite rare,
so I file this bug to handle these two rare cases.
Comment 1 Fabien Cazenave [:kaze] 2012-08-07 13:47:57 PDT
I think the 0x81 one is the most common one in Europe. I had to implement it in my Gaia branch to properly import SIM contacts, and it’s really easy:
https://github.com/fabi1cazenave/gaia/blob/simContacts/apps/contacts/js/utilities/import_sim_contacts.js#L83
Comment 2 Yoshi Huang[:allstars.chh] 2012-08-07 19:47:13 PDT
Hi kaze,
Thanks for the info.
I'll work on it
Comment 3 Yoshi Huang[:allstars.chh] 2012-08-08 02:32:47 PDT
Created attachment 650007 [details] [diff] [review]
WID - Patch to read UCS2 on ICC
Comment 4 Yoshi Huang[:allstars.chh] 2012-08-09 00:08:47 PDT
Created attachment 650457 [details] [diff] [review]
Part 1: Read 0x81 and 0x82 UCS2 String on UICC

Hi, Vicamo
This patch deals with 0x81 and 0x82 mode for UCS2 String on UICC. 
Would you help to review that?

Thanks
Comment 5 Yoshi Huang[:allstars.chh] 2012-08-09 00:10:33 PDT
Created attachment 650458 [details] [diff] [review]
Part 2: xpcshell tests

Hi, Vicamo
Because currently we don't have writeICCUCS2String yet, so I collect the test data from a real SIM.

Thanks
Comment 6 Vicamo Yang [:vicamo][:vyang] 2012-08-09 01:27:32 PDT
Comment on attachment 650457 [details] [diff] [review]
Part 1: Read 0x81 and 0x82 UCS2 String on UICC

Review of attachment 650457 [details] [diff] [review]:
-----------------------------------------------------------------

Wonderful!
Comment 7 Yoshi Huang[:allstars.chh] 2012-08-09 03:18:17 PDT
Created attachment 650490 [details] [diff] [review]
Part 2: xpcshell tests v2

update tests.
Comment 8 Yoshi Huang[:allstars.chh] 2012-08-09 20:09:58 PDT
Created attachment 650765 [details] [diff] [review]
Part 2: xpcshell tests v3

update to use \u.

Thanks
Comment 9 Vicamo Yang [:vicamo][:vyang] 2012-08-09 21:01:45 PDT
Comment on attachment 650765 [details] [diff] [review]
Part 2: xpcshell tests v3

Review of attachment 650765 [details] [diff] [review]:
-----------------------------------------------------------------

Sweet!
Comment 10 Yoshi Huang[:allstars.chh] 2012-08-09 21:11:47 PDT
Created attachment 650781 [details] [diff] [review]
Part 1: Read 0x81 and 0x82 UCS2 String on UICC

Rebase to m-c
Comment 11 Yoshi Huang[:allstars.chh] 2012-08-09 21:12:29 PDT
Created attachment 650782 [details] [diff] [review]
Part 2: xpcshell tests v3

Rebase to m-c

Note You need to log in before you can comment on or make changes to this bug.