Closed Bug 780854 Opened 7 years ago Closed 7 years ago

Overflow:hidden css class makes field labels not read by NVDA

Categories

(Core :: Disability Access APIs, defect)

14 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 501580

People

(Reporter: mpnkhan, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713134347

Steps to reproduce:

Here is a example where I use hidden css class according to (http://webaim.org/techniques/css/invisiblecontent 
http://jsfiddle.net/HMDpw/4/ 

But the hidden labels are not read by NVDA on Firefox while NVDA reads perfectly on IE and chrome


Actual results:

 The form fields are read as "Edit Auto complete Blank" on FireFox 14 with NVDA


Expected results:

Should read labels as in IE or Chrome.
Could you attach a minimal testcase please?
Component: Untriaged → Disability Access APIs
Product: Firefox → Core
Attached file Test case.
Str:
1. Open the attached test case.
2. Retrieve the accessible for the editable text field.
3. Retrieve the accessible's name.
Expected: The name should be "Field:".
Actual: There is no name.
It's also worth noting that the label element loses its own accessible when you apply overflow:hidden (except for a text leaf node). The text is merged into the parent.
Works in Firefox 3.6 (specifically: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.28) Gecko/20120306 Firefox/3.6 Firefox/3.6.28). Broken in Firefox 4 (specifically: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.2pre) Gecko/20110517 Firefox/4.0.2pre).
Keywords: regression
Btw, even in Firefox 3.6, the label doesn't have its own accessible, but it still correctly labels the field.
Seems like nobody looked at this bug for over two months now. Is Accessibility Team looped in on this?
(In reply to James Teh [:Jamie] from comment #4)
> Btw, even in Firefox 3.6, the label doesn't have its own accessible, but it
> still correctly labels the field.

we have a bug 501580 for this. Is it enough to say this bug is fixed?
(In reply to Victor Tsaran from comment #5)
> Seems like nobody looked at this bug for over two months now. Is
> Accessibility Team looped in on this?

I don't always have enough time to address all feedback unfortunately and thus some things get lost from my radar. Don't hesitate to ping me to bump the priority.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to alexander :surkov from comment #6)
> we have a bug 501580 for this. Is it enough to say this bug is fixed?
Do you mean fixed or duplicate? (That bug is still open.) If you're certain it's the same issue, I guess dupl makes sense.
(In reply to James Teh [:Jamie] from comment #8)
> (In reply to alexander :surkov from comment #6)
> > we have a bug 501580 for this. Is it enough to say this bug is fixed?
> Do you mean fixed or duplicate? (That bug is still open.) 

right, dupe. Actually I wanted to say something like "If the bug 501580 was fixed then would it be enough to say that this bug is fixed as well" :)

> If you're certain
> it's the same issue, I guess dupl makes sense.

that was my question. bug 501580 is about we don't pick up the accessible name from hidden labels. This bug might be about that we don't create an accessible for hidden labels.

If you think that we need an accessible for hidden labels (aka we need to expose label_for/by relations among other things) then let's keep this bug open. Otherwise let's mark it as dupe of bug 501580.
(In reply to alexander :surkov from comment #9)

> If you think that we need an accessible for hidden labels (aka we need to
> expose label_for/by relations among other things) then let's keep this bug
> open.

and this case let's mark it as dupe of bug 476986 :)
(In reply to alexander :surkov from comment #9)
> that was my question. bug 501580 is about we don't pick up the accessible
> name from hidden labels. This bug might be about that we don't create an
> accessible for hidden labels.
Ah. Got it. I assumed this bug was more about the accessible name.

> If you think that we need an accessible for hidden labels (aka we need to
> expose label_for/by relations among other things) then let's keep this bug
> open. Otherwise let's mark it as dupe of bug 501580.
I don't think the label accessible is particularly important, so dupl seems fine to me.
ok, marking dupe of bug 501580 per comment #11.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 501580
You need to log in before you can comment on or make changes to this bug.