Mozilla will lose track of cell height in very long tables

RESOLVED DUPLICATE of bug 89315

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 89315
17 years ago
17 years ago

People

(Reporter: ivo, Assigned: karnaze (gone))

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.8.1+) Gecko/20010424
BuildID:    2001042404

Mozilla will loose track of image position and cell background colour in case of
very long tables. 

Reproducible: Always
Steps to Reproduce:
Load URL and scroll towards the end of page.

Actual Results:  In some point block bar is not centered to the cell and cell
background is partially visible.

Expected Results:  Every image to be shown properly placed inside cells and with
full background colour.
(Reporter)

Comment 1

17 years ago
Created attachment 32565 [details]
bar in question
(Reporter)

Comment 2

17 years ago
As Bugzilla refuses to let me upload a testcase to it system I put this testcase to:

http://www.vendomar.ee/~ivo/backg.html

Comment 3

17 years ago
Confirming on build 2001042608 Linux

It looks like the cells themselves are not maintaining correct height, ie. the
image positioning and cell background are correct but the height of the cell
itself is not carried across the row.

Comment 4

17 years ago
Yes, I can reproduce the boooog

User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.14-5.0 i686)
BuildID:    2001032614

Comment 5

17 years ago
I can reproduce the bug on Win98 using Win32 build 20014042820.

When you reload the page, the location where the problem occured is not the same.
In other words, you cannot exactly reproduce the number of cells having
incorrect height.

Comment 6

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

Comment 7

17 years ago
Created attachment 32657 [details]
Testcase HTML file

Comment 8

17 years ago
Created attachment 32658 [details]
Testcase GIF file (Save it as a.gif)

Comment 9

17 years ago
Provided a testcase demonstrating the problem.
The testcase needs a GIF to work with.  Get the little GIF from the attachment 
above.
(Reporter)

Comment 10

17 years ago
Page
http://www.vendomar.ee/~ivo/backg1.html
does not have this problem, but page
http://www.vendomar.ee/~ivo/backg2.html
does have it.

Comment 11

17 years ago
*** Bug 81910 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
*** Bug 86311 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
Changing summary since the DUPs show that it doesn't have anything to do with
the image/bg in particular.
Adding keywords.
Another example: http://www.zophar.net/zsnes/spc/
Keywords: 4xp, mozilla0.9.3, nsbeta1
Summary: Mozilla will loose track of image position and cell background colour in case of very long tables. → Mozilla will loose track of cell height in very long tables
Changing summary to "lose", as the reporter likely intended (formerly "loose").
Summary: Mozilla will loose track of cell height in very long tables → Mozilla will lose track of cell height in very long tables
(Assignee)

Comment 15

17 years ago

*** This bug has been marked as a duplicate of 89315 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.