Last Comment Bug 781039 - Mouse input support for gonk
: Mouse input support for gonk
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget: Gonk (show other bugs)
: unspecified
: All Gonk (Firefox OS)
: -- normal (vote)
: mozilla17
Assigned To: Michael Wu [:mwu]
:
Mentors:
Depends on:
Blocks: 769167 781178
  Show dependency treegraph
 
Reported: 2012-08-07 16:33 PDT by Michael Wu [:mwu]
Modified: 2013-10-29 06:58 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
WIP for mouse support (5.37 KB, patch)
2012-08-07 16:34 PDT, Michael Wu [:mwu]
no flags Details | Diff | Review
Add GeckoPointerController (4.34 KB, patch)
2012-08-20 17:47 PDT, Michael Wu [:mwu]
cjones.bugs: review+
Details | Diff | Review
Draw a pink square cursor in B2G for testing (1.66 KB, patch)
2012-08-20 17:49 PDT, Michael Wu [:mwu]
no flags Details | Diff | Review
Draw a pink square in B2G for testing, v2 (1.56 KB, patch)
2013-10-29 06:58 PDT, Michael Wu [:mwu]
no flags Details | Diff | Review

Description Michael Wu [:mwu] 2012-08-07 16:33:44 PDT
We need mouse support for the pandaboard.
Comment 1 Michael Wu [:mwu] 2012-08-07 16:34:34 PDT
Created attachment 649869 [details] [diff] [review]
WIP for mouse support
Comment 2 Malini Das [:mdas] - Away, not checking bugmail 2012-08-09 12:33:57 PDT
This patch works well, but if you change orientation, the mouse does not switch and follows the previous setting's boundaries
Comment 3 Michael Wu [:mwu] 2012-08-20 17:47:49 PDT
Created attachment 653601 [details] [diff] [review]
Add GeckoPointerController

This allows us to send events for mice.
Comment 4 Michael Wu [:mwu] 2012-08-20 17:49:15 PDT
Created attachment 653603 [details] [diff] [review]
Draw a pink square cursor in B2G for testing
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-08-24 20:01:23 PDT
https://hg.mozilla.org/mozilla-central/rev/0eb750ce354b
Comment 7 Michael Wu [:mwu] 2013-10-29 06:58:00 PDT
Created attachment 823995 [details] [diff] [review]
Draw a pink square in B2G for testing, v2

Refreshed this patch since I needed to use this yesterday.

Note You need to log in before you can comment on or make changes to this bug.